Can't Resize Images after 5.6.6+4375 Update

I added a custom image size and it didn’t resize the next image I added. Then I tried to regenerate the thumbnails and got this error:

This tool won’t be able to do anything because your server doesn’t support image editing which means that WordPress can’t create thumbnail images. Please ask your host to install the Imagick or GD PHP extensions.


Hi @digi57,

Thank you for using Local :slight_smile:

PHP 7.4.1 in Local does have ImageMagick included and enabled by default.

In newer versions of Local, PHP 7.3.5 includes ImageMagick, but it’s not enabled. It can be enabled by editing the site’s “conf/php/php.ini.hbs” file.

If you need ImageMagick now, I recommend hot-swapping your site’s PHP version to 7.4.1.

Let us know if you have any questions or concerns.


1 Like

Hi Elena,

I tried hot-swapping to 7.4.1 and although it the error I posted no longer appears, I instead get: ERROR: The current image editor cannot process this file type.

Here is the image info:
File type: image/jpeg

Uploaded on: July 24, 2020

File size: 751 KB

Dimensions: 5760 by 3840 pixels

Also, adding the image does not automatically resize.

What do I need to do to edit the php.ini.hbs file?

I really need to be able to have custom image sizes. Should I just roll back to the last version of Local? If yes, how can I do that?

1 Like

Tx. I had the same problem but updating to 7.4.1 worked for me.

Hey @digi57

That error message:

Seems to point to an issues with the actual image. You might take a look at this Github issue for more info along with a possible workflow for solving this:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.