BUG: Plugin update fails for plugins installed using wp-cli

I installed a plugin using wp plugin install wordpress-seo --activate

When a new version was released and I tried to upgrade it from wp-admin->plugins I got:

I suspect the web server (ngingx) don’t have rights to overwrite the old file while updating the plugin.

I’ve experienced the same issue.

I’ve also tried to manually reinstall the same plugin but it’s not working.

Please advise.


Hi all,

This is an issue with the current iteration of Faster Docker Volumes for macOS. There’s been a bug with the built-in version of the NFS server (what FDV uses) on macOS since El Capitan.

One solution is to go to Settings » Advanced and disable FDV. However, I know that’s not ideal since it’ll drastically slow down Local sites.

Here’s another temporary solution but I don’t believe the success rate is quite as high: Plugin / Theme updates fail when Faster Docker Volumnes ON

With all of that said, we’re actually in the testing phase of Faster Docker Volumes version 2 on macOS. It doesn’t use the built-in version of macOS’s NFS server. There are several users who have tested it and it completely eliminated this issue with no side-effects that we’ve seen so far.

You can expect to see Local with FDVv2 sooner than later :slight_smile:

1 Like

You can force install the plugin, just ssh into the local site and do (replace wordpress-seo with your plugin slug):

wp plugin install wordpress-seo --force