Plugin / Theme updates fail when Faster Docker Volumnes ON


I’m using v.2.0.6 Mac, and theme and plugin updates fail right away if I have Faster Docker Volumes switch ON in the preferences.

If I turn it off, updates work no problem.

Actually came here to look for others who have this problem in Local 2.0.6 Mac.

It just reared its ugly head again here when I tried to update ACF Pro: “can’t remove old plugin files” error followed by “all plugin files were in fact removed, but not their directories --> plugin not found and has to be manually re-copied in Finder” error.
I’m sure turning Faster Docker Volumes off would make updates possible again, but then I don’t really feel that’s a satisfactory way forward.

Same issue for me “can’t remove old plugin files” but the bug doesn’t happen each time I do an update, this is a random bug…

Hey all,

It may be a permissions problem. Props to @galen for bringing this up in Add one click "Fix Permissions"

Here’s what you can try:

  1. Open Terminal
  2. Change to the site’s folder using cd. Example: cd ~/Local\ Sites/test
  3. Run: find ./app/public/wp-content -type f -exec chmod 644 {} \; ; find ./app/public/wp-content -type d -exec chmod 755 {} \;

The command above will set all files to 0644 and all folders to 0755 which are safe defaults.


Could not configure Faster Docker Volumes on Windows 7 and could not find such setting there:

Permission fix doesn’t work for me (error: can’t remove old plugin files).
I had to disable Faster Docker Volumes to run the updates.
MacOs High Sierra, Local 2.08

Can you try running a recursive chown on the site directory? You’ll want to run this command in Terminal and not inside the site’s “SSH”.

Here’s an example:

chown -R $(whoami):staff ~/Local\ Sites/test/app

Just had another random plugin update error in Local 2.0.8: 2 out of 10 updates failed with the “Could not remove the old plugin.” message.

Haven’t tried running chown in terminal yet, but from the look of it I can’t see any difference in owner/user/permissions between directories/files that worked (Members, WP Migrate DB Pro) and the two that failed (Polylang and Events Calendar).

Notice that in each of the failed plugin directories there remains a single file, everything else was properly deleted in preparation of the update.

Seems like this isn’t really random after all.

Being a bit curious, I deleted and re-imported the site from a Local archive multiple times now, and went through exactly the same moves and updates.

  1. Reimport, update all plugins as before: the same 2 plugins fail to update.
  2. Reimport, do chown -R $(whoami):staff, update all plugins: the same 2 plugins fail to update.
  3. Reimport, turn off Faster Docker Volumes, update all plugins: everything updates just fine.

Somehow, somewhere, Faster Docker Volumes is (still) involved in this.

Nothing, same issue…

I’m having this problem again too, now running Local 2.0.8. It seems to consistently happen with larger plugins like Yoast’s SEO plugin, but not with everything. Turning off Faster Docker Volumes really slows things to a crawl. I hope this bug gets squashed soon.

I’m happy to volunteer trying things and submitting logs if it helps.

As an additional note: I already tried resetting permissions and ownership of files and folders using Terminal.

Local is such a beautiful app, but this has been a consistent issue since I started using it four months ago, regardless of resetting permissions and ownership. I just updated to Local 2.1.1 in hopes this would be fixed, but alas, same issues, different day. This is a deal breaker. I’d happily pay for a stable version, but it’s back to crusty old MAMP until this is figured out.

Same thing with version 2.1.2, same issues. I would also be happy pay for a stable version, but it’s back to crusty old MAMP until this is figured out.

Unpacking the update…
Installing the latest version…
Removing the old version of the plugin…
Plugin update failed.
An error occurred while updating XXXXXXX: Could not remove the old plugin.

It wil get fixed prob in local 2.2 as the faster docker volumes wil get updated.

The same thing here, but I will wait the 2.2 for the fix.

Long life Local FlyWheel

I’m having this problem again using 2.1.2, although usually only with larger plugins such as WooCommerce and Yoast SEO.

Hey all,

2.2.0 (pre-release) is now available. It should resolve this issue: Local by Flywheel 2.2.0 (Pre-release)

Please let us know how it works for you!

Still not letting me update certain plugins even after updating to 2.2.0.

Please fix this asap.

Hey Lars,

Did you try the latest 2.2.3?