Cannot get Local working on Mac - I can't be the only one seeing this?

Hi All (and Clay :wink: )

OK this is a source of major frustration for me. I’ve worked with Clay to resolve this on many occasions and at the point of giving up completely.

Mac Sierra
Completely removed Local, Docker and Virtual box installs from my machine using appcleaner. Then I download Local 2.0.6 (Download Local by Flywheel 2.0.6 for macOS), extract to Applications folder then run Local by Flywheel.

I then get a green bar on the left, white space on the right saying Checking System and thats it (randomly wants to regenerate the certificates). Nothing runs, interface just sits there.

I then try some commands Clay sent me last time which don’t help either.

/Applications/Local\ by\ Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine rm -f local-by-flywheel

/Applications/Local\ by\ Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine create local-by-flywheel

This creates a machine, however Local cannot seemingly start it up or connect to it

I’m at a loss, surely i’m not the only mac user having these issues - all I want is an easy to use local dev env for wordpress and php sites?

Simon

It’s hit or miss for me but I’m also experiencing this issue at the moment.

@whitneywooyy @SimonAntony

Can you both try upgrading VirtualBox to 5.1.26? You can download it here: https://www.virtualbox.org/wiki/Downloads

Please let me know if that helps. So sorry for the trouble!

@clay - I had a working machine on Monday, started Local up today and it’s not working again. Just updated virtual box and restarted Local, same thing, regenerating certs etc - going to do my usual kill, create, startup again

Simon

@SimonAntony,

Can you try running the following in Terminal?

/Applications/Local\ by\ Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine kill local-by-flywheel

then

/Applications/Local\ by\ Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine start local-by-flywheel

Also, here are some relevant Docker GitHub issues I’m seeing:


Hi - sorry for delay, it’s been behaving but discovered something interesting.

If I get Flywheel running, it stays stable for days (running on my laptop so I just sleep when not using it). However I rebooted this morning and got the usual cannot start, regenerating etc

The links you post above you’ve sent me previously, still does not help us solve anything though.

So after a reboot, it’s now dead again - I tried the two commands above, same thing.

$ /Applications/Local\ by\ Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine kill local-by-flywheel
Killing “local-by-flywheel”…
Machine “local-by-flywheel” was killed.

$ /Applications/Local\ by\ Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine start local-by-flywheel
Starting “local-by-flywheel”…
(local-by-flywheel) Check network to re-create if needed…
(local-by-flywheel) Waiting for an IP…
Machine “local-by-flywheel” was started.
Waiting for SSH to be available…
Detecting the provisioner…
Started machines may have new IP addresses. You may need to re-run the docker-machine env command.

So guess all I can do now is reimage, clear out and install again using my command line settings.

Soooo frustrating, all I want is a local development environment that is quick and easy to setup

Simon

Hi Simon,

The output of those two commands look good.

One more command you can try is /Applications/Local\ by\ Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine env local-by-flywheel after running the start command. It won’t do anything, but it may provide valuable output.

$ /Applications/Local\ by\ Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine env local-by-flywheel
Error checking TLS connection: Error checking and/or regenerating the certs: There was an error validating certificates for host “192.168.99.100:2376”: tls: DialWithDialer timed out
You can attempt to regenerate them using ‘docker-machine regenerate-certs [name]’.
Be advised that this will trigger a Docker daemon restart which might stop running containers.

1 Like