"Cannot read property 'version' of undefined

Issue Summary

I cannot access my local WordPress anymore. When I click on it under “Local Sites”, it gives me an error message:

How can I repair it?

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

Just on one site.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?



I did several things at once that lead to the error, so I don’t know which one caused it:

  • Update PHP 7.4.1 version
  • Trust certificate
  • Update to Wordpress 5.8

Neither the PHP update nor the WordPress update worked. When I tried to update WordPress from Local Overview it told me it doesn’t work, when I tried to do it from the WordPress admin area, it told me an update was already in progress. The PHP update also didn’t finish correctly, it just wanted to do it again and again. In the end, the error messages (like above) started appearing.

System Details

  • Which version of Local is being used?


  • What Operating System (OS) and OS version is being used?

Windows 10 professional

  • Attach the Local Log. See this Community Forum post for instructions on how to do so:

local-lightning.log (395.6 KB)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.