Local Community

Cannot reset local site's WP admin password

Im a novice so correct my jargon for me please- the system is dedicated to a developer with his own business (i think). Login page for the Wordpress site is setup to authenticate against a different system (for example, i have to authenticate against this developers internal login system).

Hes terrible with comms so im guessing what the issue is here. but ive ran out of ideas. I have exhausted resetting passwords through ‘Lost ur password’? and also through WP-CLI method

This method is best for creating new admin accounts in case you don’t know an existing admin username/e-mail. - this is what my problem is. when i enter the local username it gives ‘not recognised username’ and when trying with dedicated username the developer set up especially for me to access his control panel it shows ‘your answer is incorrect’

NO IT ISNT LOL

im pulling whatever hair i have left out so please pitch in

Create a new admin user with WP-CLI in the Site Shell.

I wasnt clear in what i’d done with WP-CLI so far. Ive actually already tried creating a new user through this. and no luck

What error did you get?

Same here. I set up a new site and copied my password to a temp location. The site started no issues, however I couldn’t log into wp-admin. I searched for a method and emails aren’t being caught my mailhog so I went the cli route. (Disclaimer: I’ve never used WP CLI via Local before)

I get “Error: This does not seem to be a WordPress installation.”

Interestingly, the shell opens in my Windows User directory (while I chose my second drive as a location for the site). Not sure why it’s not dropping me in the correct directory. If do cd s: it shows me the path to the site’s app\public directory on my S:\ drive, then kicks back to my user profile on c:.

@TyantA & @fraser,

One thing that may be worth trying is resetting the password using Adminer which can found under the “Database” tab in Local.

Once Adminer opens, you can change a user’s password by doing the following:

  1. Navigate to the users table (wp_users by default)
  2. Click on “Edit” beside the user you want to edit
  3. Type in the desired password in the user_pass column
  4. Select “md5” in the dropdown in the user_pass column
  5. Log in using the new password

Note: WordPress will automatically rehash the password using salts after you log in.

Here’s a GIF showing steps 1-4:


@TyantA,

Got it. I’ve made a note to dig into this.

1 Like

Thanks @clay! I’m in on both sites. So in both cases, it’s like the password I specified during setup didn’t take / was replaced by a generated one anyway. That or maybe I didn’t have what I thought I had copied. In any case, I’m in, so thanks!

Thanks so much for this Clay! I’ve been struggling to get on to a site I cloned from a Blueprint and this has sorted it straightaway!

Hi

I have the same issue, when I change the password as you suggest to something generic, and do not change the drop down to md5, but just as the blank option, and save - the password behaves as expected, however when I try and log in to wp admin, the password doesnt work. So I went back and selected md5 in teh drop down, and an automated password is created, so I cant get in. Any help much appreciated

In hopes of not starting a completely different topic, when I edit a user in the Adminer, the new password still doesn’t work. It is also failing to send me a password reset email when I try to reset my password while logging into the admin. I’ve tried a variety of different passwords. Saved and closed adminer, refreshed the admin page, restarted the local instance of the site, and even tried with chrome in incognito mode, and nothing lets me log into the site through Local. Any help would be appreciated!

@gearsighted Emails from WP sites within Local are captured by Mailhog. Within the Local interface, select the site, then the Tools tab on the right, then Mailhog, then finally “Open Mailhog”. You should see the emails that you’re looking for within the inbox.

1 Like