Cannot use WAMP because of Local

Issue Summary

I have both Local by Flywheel and WAMP installed on one system on PC. But when I attempt to use any of the WAMP services, I get the 404 Error page by Local by Fywheel.

I have tried turning of Local and tried accessing any single service on WAMP, like Adminer, PHPMyAdmin, virtual hosts manager, etc… But all show the same issue because of Local.


Install Local, and install WAMP.

System Details

  • Which version of Local is being used? 5.9.3

  • What Operating System (OS) and OS version is being used? Windows 10

  • Attach the Local Log. local-lightning.log (553.8 KB)

Hey @elliottmangham!

The issue is that both programs are trying to use the same HTTP port of 80. Because only one tool can use that port at a time, you’ll need to stop both applications, and only start the one that you are wanting to use at that time.

A different option would be to let WAMP use it’s default location of port 80 and instead have Local run in "localhost Router Mode", which is a setting you can toggle at “Preferences > Advanced > Router Mode”.

What this setting does is disable Local’s router, which means that instead of pretty urls like example.local, the browser would be accessing the Local site directly on a url that looks something like localhost:10015

Here’s a help doc that has more info about Local’s Router Mode:

Hi @ben.turner,

Thank you for your response. This seems to address the issue.

Bizarrely though, since I installed WAMP, having already had Local installed - many buttons on the Local interface no longer work. For example, the View Site, Admin, Open Adminer, Open Mailhog buttons all do not work. I’ve tried restarting.


That’s definitely odd. I wonder if WAMP is doing something that is colliding with the ports for those other tools of the Local site.

If you create a new site in Local does that help? My thinking is that this will “re-flush” the ports that are used by Local.

Thanks @ben.turner, I will try that! On another note, I don’t suppose you could check this out can you? SSL certificate problem on Windows

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.