Heads-up! Local's router is having trouble starting - Win 10

Not able to use Local flywheel.

Any help?

Which version of Local are you using?

Hey i am having the same issue. I am on verison 5.2.4. local-lightning.log (47.8 KB)

Same issue here. On version 5.3.2

We’ve shipped a lot of fixes in the two most recent versions of Local. Does downloading the latest Local version help? Download here: https://localbyflywheel.com/?download

Hi, i am not able to view my page. it says - Heads-up! local’s router is having trouble starting
Please help.

I am on 5.3.1+3095 (the most recent released build) and I have the same problem. When I click on view site, I get a 404 page from IIS. I’m assuming there must be some kind of conflict. How do I change the ports that are used by Local so I use something other than 80 and 443?

Local runs on ports 80/443 you will need to turn off IIS.

Yes, I know that. But under the hood the router appears to be nginx and nginx can be configured to run on a different port. 8080 is one often used when there is a conflict between webservers. Has anyone gone into the router nginx config files and changed the port number to 8080 and 8443 or will local just change it back when it restarts? That was the question I was trying to ask.

So I changed nginx.conf and server-block.conf from listening on port 80 to 8080 and server-block-ssl.conf to listen to port 8443 vice 443 and restarted the site. The router warning went away (as I predicted) but accessing the site via the Admin or View Site buttons was a mostly no go. If I put :8080 in the urls then it sort of worked sometimes but as soon as it tried to redirect or get other resources it would not work. That seems to indicate that local could have an ability to set other ports for the router but there’s something missing in local that would allow that to propagate to the site itself. That’s a bummer since I have to have IIS running on my dev machine where I create .net sites as well as wordpress. Any chance that could be added as a feature?

Failing this, I switched over to localhost mode and the site works but no SSL glory. I’d really like this to work. :roll_eyes:

PS. The conf files I changed were in the Program Files (x86) location and not the appdata location since those files seem to get overwritten by whatever is in the Program Files location. And I did confirm that nginx was listening on 8080 and 8443. It’s just that the site wasn’t configured to work well with that configuration.

1 Like

Just to try everything, I shutdown IIS and I’m still getting a problem when I try to use the sites router mode. I get the following error msg:

2020/04/21 18:44:05 [emerg] 31284#23840: bind() to failed (10013: An attempt was made to access a socket in a way forbidden by its access permissions)

So maybe something else is going on?

OK so on Windows 10 you have to stop the http service in order to use the router’s site domains setting. That’s not good since many things depend on that service other than just IIS. That includes a number of base services including the Print Spooler, SSDP and Windows Remote Management. On my machine SQL Server Reporting Services also depend on that service.

Please allow for a way set the ports for the nginx router so developers on Windows 10 can use router mode.

Having the same message on version 5.4.1. Please resolve this issue. Thanks.

Problem solved. It requires that the router site location is set to localhost. Click in the upper left hand corner where the lines are. Then click Preferences. Then click Advanced. Then click on the Router Mode option. Set it to localhost. You may have to delete the site and recreate it but it does solve the problem.

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.