Local Community

Cannot validate Purchase Key. Please try again later. If the problem persists your server might not have the curl PHP extension enabled

Bonjour, je travaille pour la première fois sur LOCAL. J’ai installé hier un nouveau site wordpress avec un template. Une fois le template activé, il me demande de rentrer le code d’achat. et voici le message que j’ai lorsque je valide mon code d’achat “Cannot validate Purchase Key. Please try again later. If the problem persists your server might not have the curl PHP extension enabled.”

Comment est ce que je peux corriger ce problème sur LOCAL?

MERCI BEAUCOUP A TOUS !
Guillaume

[Google Translate]

Hello, I am working on LOCAL for the first time. I installed a new wordpress site yesterday with a template. Once the template is activated, it asks me to enter the purchase code. and this is the message I get when I validate my purchase code "Cannot validate Purchase Key. Please try again later. If the problem persists your server might not have the curl PHP extension enabled. ”

How can I correct this problem on LOCAL?

THANK YOU VERY MUCH TO ALL !

Hey @GuillaumeTin – Welcome to the Local Community Forums!

It’s hard to know exactly what’s going on. Local sites should have the curl extension enabled, but maybe the registration is failing because of a different reason? Can you provide some more details about what’s going on:

  • What version of Local are you using?
  • What Operating System and OS version is being used?
  • Can you please provide your Local Log? See this Community Forum post for instructions on how to do so:
  • What theme are you trying to activate?
  • Can you provide a zip of the logs folder under the site’s folder? You should see logs next to app.

[Google Translate]

Salut @GuillaumeTin – Bienvenue sur les forums de la communauté locale !

Il est difficile de savoir exactement ce qui se passe. Les sites locaux devraient avoir l’extension curl activée, mais peut-être que l’enregistrement échoue pour une raison différente ? Pouvez-vous fournir plus de détails sur ce qui se passe :

  • Quelle version de Local utilisez-vous ?
  • Quel système d’exploitation et quelle version du système d’exploitation sont utilisés ?
  • Pouvez-vous s’il vous plaît fournir votre journal local ? Consultez cet article sur le forum de la communauté pour savoir comment procéder :
  • Quel thème essayez-vous d’activer ?
  • Pouvez-vous fournir un zip du dossier “logs” sous le dossier du site ? Vous devriez voir “logs” à côté de “app”.

Bonjour, merci pour votre réponse. Alors je vais essayer de répondre à tout.

  • version LOCAL 6.1.4+5521
  • je travaille sur MAC OS HIGH SIERRA 10.13.6
  • voici le journal LOCAL
    local-lightning.log.zip (2.3 KB)
  • j’essaye d’activer le thème LAGAR (Lagar - Winery Wine Shop WordPress by vamtam | ThemeForest)
  • désolé je ne vois pas de quoi vous parlez ( * Can you provide a zip of the logs folder under the site’s folder? You should see logs next to app.)
    Bonne journée
    Guillaume
    MERCI

Please try upgrading to WordPress 5.8.2 that was released today. Most helpful is this fix that may address your issues:
ca-bundle.crt contains expired certificate DST Root CA X3

see: Custom Query – WordPress Trac

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.