Local Community

Can't access ANY of our WP Engine sites by browser after LocalWP install - 403 error

After install, I cannot navigate to ANY of the 23 WP Engine sites.

Description

I installed Local and pulled 1 site locally.

Now I get 403 Forbidden errors on ALL the sites on WP Engine, after connecting.
This happens for ALL our WP Engine sites, even though I’m only working on 1 site.

Replication

I had an existing server running and built on my machine using the EXISTING Apache from OSX, and installing PHP (brew), Certificate + CA, and MySQL (brew).

I did click the localhost checkbox in LocalWP. I have since Uninstalled LocalPM to try to remove this issue.

System Details

This is on OSX 12.5.1 - Monterey.

-=-=-=-=-=-=-=-

My guess is that this is something in the hosts file. But which hosts file? and how do I fix this?
I tried uninstalling LocalWP and it STILL did not remove the configuration that caused this.

How do I remove this configuration, and get browser access to the remote sites again?

Hello @WPSuperheroes - thank you for bringing your question the Local community.

Can you clarify, when you say you get a 403 Forbidden error on all the sites you have on WP Engine, are these live sites? Can you provide an example so I can see what you see?

A screen shared video may be helpful as well.

Let’s get this sorted!

Sam

Here is a video:

Here is someone else with a very similar problem who ALSO was stuck like me for over 2 days.

And here is where I posted it on these Forums for the 1st time, but did not receive a response.

Your support is appreciated.

Have you checked the default MacOS hosts file in /etc/hosts? Are there entries for the WPE sites in there?

What are you seeing in the Network tab of the browser’s dev tools when you try to connect to the front-end of a site (like mariasplace.com)? Is it trying to hit the correct IP address, or a local IP address?

Yes, I also checked this file. It held the same thing. Only reference to the single site downloaded.

I reset EVERYTHING, then eventually gave up and shut the computer down.
I don’t know what solved this, but it seems to be solved now.

1 Like

Sounds like either local resolver or browser caching of the host lookup.

Glad that you’re moving forward again.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.