Uh-oh we ran into an issue when pulling from WP engine

Issue Summary

Unable to pull any sites from WP Engine.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    All sites
  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?

    • For example: macOS Catalina or Windows 10 Professional
      macOS Ventura
  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @simplefocus

Are you using any other developer applications? I see some potential port conflicts in the logs. Apps like MAMP, XAMPP, or Docker for example.

Can you try the steps here to reset and see if that works?

After that if you’re still having trouble feel free to share an updated Local Log and we can go from there.

Thanks for the quick response @Nick-B

I’ve re-gen’ed the API credentials and killed anything running on port 80 on my local and still getting the same error.
local-lightning.log (103.3 KB)

What about Port 443? I still see that getting flagged as well.

As a workaround, are you able to download a backup of any sites and direct import them?

@Nick-B seems that 443 is only being used by my web browser, nothing else.

It seems to be the error is stemming from this rsync process failing
{"thread":"main","class":"WPEPullService","stack":"Error: rsync process existed with code 12\n at ChildProcess.<anonymous> (%%appPath%%/main/rsync/RsyncService.js:1:1183)\n at ChildProcess.emit (node:events:527:28)\n at ChildProcess.emit (node:domain:475:12)\n at ChildProcess._handle.onexit (node:internal/child_process:291:12)","eventId":"42406d9c3d47429c8244ec0991cf0678","level":"error","message":"rsync process existed with code 12","timestamp":"2023-06-21T19:24:11.221Z"}

Were able to give the direct import a try?

The direct import worked but kinda reduces the simplicity of just pulling down a site automatically

I understand it’s not as elegant I just wanted to make sure it worked at least as an alternative option. It also helps us to narrow our troubleshooting focus. Are any of the sites you are working on overly large? Do they have lots of media, big databases, etc?

1 Like

@Nick-B Nope, the site I’m trying to pull down is a brand new blank site created on WPE

Could you send over an updated Log? That way I can check the new one and compare. Thank you for all your patience and communication with this as well :slight_smile:

Sure thing! And thanks for all your help

local-lightning.log (127.6 KB)

Thank you for that!

Still not sure about a specific culprit, but have a couple more ideas to check:

  • Does your machine have enough disk space? Sometimes insufficient disk space can cause the timeouts/errors we see in the log.

  • Are you able to test on an alternative work to rule out any connectivity issues? Could you test with/without a VPN to see if that works?

  1. Disk space – there’s plenty of that 412 GB available
  2. I don’t have a VPN to test but I can assure that connectivity isn’t an issue.

Do you have any peers that are having the same issue? Are you able to test from another machine?

With your permission, could I test pulling down the same site you tried and see if it will load for me?

Colleagues are able to pull stuff down.

Feel free to try to pull down the same site

Okay well if your colleagues are able to pull stuff down normally, then that negates the point of my test. It seems the issue is specific to your machine/connection. I’m assuming you’ve tried all manner of restarts, reboots, and tried resetting your API credentials already. You’re still able to directly import a backup so the site shouldn’t be the problem especially if it’s small and Local is still able to accept and spin it up.

To do a more aggressive reset, you could give the below steps a try:

  • Export any sites that you have on Local and save them to a folder somewhere on your computer.

  • Fully uninstall Local from your computer.

  • Install the latest version of Local on this link.

  • Once installed, please restart the computer.

  • When the computer is restarted and turned on, close any applications that automatically run in the background (AntiVirus, Firewall, and other Developer applications included).

  • Run another reset of your WPE credentials: Troubleshooting Connect to WP Engine - Local

  • Check and see if the issue still persists. If so, please provide us with an updated log. Retrieving Local’s Log File

I had this same error message (as well as Local couldn’t load the file list! when trying to pull a new site) weirdly only on WP Engine sites. Flywheel sites continued to push and pull fine.

Thanks to this thread I discovered /Library/Logs/local-lightning.log where I saw

{"thread":"main","class":"RsyncService","message":"/Users/jacob/.ssh/config line 2: garbage at end of line; \"#\".\r\n","level":"warn","timestamp":"2023-07-24T21:12:40.766Z"}
{"thread":"main","class":"RsyncService","message":"rsync: connection unexpectedly closed (0 bytes received so far) [Receiver]\nrsync error: unexplained error (code 255) at io.c(226) [Receiver=3.1.3]\n","level":"warn","timestamp":"2023-07-24T21:12:40.767Z"}
{"thread":"main","class":"ConnectManifestWpeService","sentryEventId":"6552717388124a9aa27e22a16cd98858","level":"error","message":"Error creating manifest for WPE Service","timestamp":"2023-07-24T21:12:40.769Z"}
{"thread":"main","class":"ConnectManifestWpeService","level":"error","stack":"Error: rsync process existed with code 255\n    at ChildProcess.<anonymous> (%%appPath%%/main/rsync/RsyncService.js:1:1548)\n    at ChildProcess.emit (node:events:527:28)\n    at ChildProcess.emit (node:domain:475:12)\n    at ChildProcess._handle.onexit (node:internal/child_process:291:12)","message":"rsync process existed with code 255","timestamp":"2023-07-24T21:12:40.769Z"}

Helped me discover a line in my ~/.ssh/config that had both config and a comment:

IdentityFile ~/.ssh/id_rsa # set default so it doesn't just use newest

Turns out some programs (like rsync apparently) really need comments to be strictly on their own line starting with # so I edited my ~/.ssh/config and now Local is pushing and pulling to WP Engine again.

# set default so it doesn't just use newest
IdentityFile ~/.ssh/id_rsa

@unitof Thank you for coming by and sharing the details of your troubleshooting and resolution for other users!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.