Can't connect to site

I recently started having issues with my CSS changes not updating in development. After searching the forums, I tried the steps that Clay suggested about creating a custom environment. However, now when I create a site, it says Wordpress installation failed, even though there are wordpress files in the public folder.

After I closed out of Flywheel and restarted, when I try to view the site, it says that the site cannot be reached. I tried uninstalling and re-installing Flywheel, restarting my machine and am having the same errors. So essentially, I am having three issues, the biggest of which being that I cannot view a site in development. This happens with sites that are .local and .dev.

I’m using a MacBook Pro running High Sierra, but this problem occurred even before I updated to High Sierra. I thought updating might help.

No idea what happened, but I brought my laptop downstairs and re-opened Local and suddenly things are working. Created a new site and no Wordpress installation issues. Haven’t tested the CSS issues, but I’m at least happy that these things are working.