Updating to 2.3.2 and Updating environment & Can't push to or pull WP sites from Flywheel FIX

Ok I’ve updated both my application and the website environments. When I did that I got all kinds of errors and issues that I had never had before. FWIW, I’m using a mac.

The issues were:
-Unable to back up after stopping a site
-Site Container missing
-sql issues
-Cant push or pull site to flywheel due to it not being wordpress, when they all are.

Here’s how I fixed all of the issues

First After Updating everything I tried to start and stop each site. Once I finally stopped them all, I force quit the local app and restarted it. Then it was stuck longer than usual at “Starting Local Machine” for a bit. So I force quit again, then opened it. This time i was still stuck at starting local machine so I left it alone. I’d say maybe 2 minutes later it started the local machine. Then I closed it out one more time just to see if it would open as normal. I did relaunched local and it started local machine pretty fast.

For the site that was missing the site container, I restored the site and its fine.

The last issue I have is that I couldn’t push or pull anything to Flywheel. The way to fix that is to click on the “connected to flywheel” cloud icon on the left site of Local. Then in the right hand corner, click on your name and log out. Then log back in, click accept, open or allow when it prompts you and then you should be led back to local where everything will be back to normal.

I hope that helps. The force quitting steps may not be required, but it worked for me.

Also, I actually can’t remember if it was the same before the update or not, but you do have to start the site you want to push or pull before the it lights up green to allow you to do so.


Thanks! It was also telling me my sites weren’t WordPress, so I followed your advice, clicked into the connect tab and back and now it’s identifying them as WordPress again.

1 Like