Can't create a site (Mac M2/M3 2024)

What issue or error are you experiencing?

Hi, I am unable to create a new site, I tried both the Apple Silicon and Intel builds. Mac Sonoma 14.4. The error is the same, on first boot up this screen appears and the site deletes itself.

Error: Command failed: /Users/user/Library/Application Support/Local/lightning-services/mysql-8.0.16+6/bin/darwin/bin/mysqladmin ping
amysqladmin: connect to server at 'localhost' failed
error: 'Can't connect to local MySQL server through socket '/Users/user/Library/Application Support/Local/run/_W9Dckdrh/mysql/mysqld.' (2)'
Check that mysqld is running and that the socket: '/Users/user/Library/Application Support/Local/run/_W9Dckdrh/mysql/mysqld.sock' exists!

at ChildProcess.exithandler (node:child_process:430:12)
at ChildProcess.emit (node:events:513:28)
at maybeClose (node:internal/child_process:1091:16)
at ChildProcess._handle.onexit (node:internal/child_process:302:5)

Verified on two different computers, same problem.


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc


System Details

  • Local Version: 8.3.2

  • Operating System (OS) and OS version: Sonoma 14.4


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

On Apple Silicon, Local currently requires Rosetta.

You can install it by bringing up a terminal and typing:

softwareupdate --install-rosetta

Then restart Local. You should be able to create sites without the MySQL error.

Hi @nickc

I have installed Rosetta and restarted Local, but it’s still not working.

Thanks for trying that, @localwpuser4711.

Please can you run this command from the terminal?

/usr/bin/pgrep -q oahd && echo Yes || echo No

If you see “No” it means Rosetta didn’t complete installion. You can try running softwareupdate --install-rosetta --agree-to-license, running the command above to check Rosetta was set up, then launching Local again.

If you see “Yes” and Local sites still do not start, please could you share your logs?