Unable to start site - mysqladmin: connect to server at 'localhost' failed

What issue or error are you experiencing?

“Can’t connect to local MySQL server through socket. Check that the mysql is running at that the socket exists!”
Screenshot 2024-06-04 at 7.53.16 AM

Unable to start site due to the above error.
Tried copying the site. Tried changing routing. Tried rebooting. Is there any way to recover the current database?


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc


System Details

  • Local Version:
    Version 9.0.3+6684

  • Operating System (OS) and OS version:
    macOS Sonoma 14.5 (23F79)


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
local-lightning-verbose.log (588.3 KB)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @eMouse

If you create a new, blank site in Local can you access that okay? If you can, then you may want to try reimporting the site getting the errors. The steps would look like this:

  • Locate the site files on your machine, and save a copy of them to your desktop. If you click Go to Site Folder under your site name it should take you right to where they are located.
  • Once you have those copied, completely delete the site from Local
  • Restart Local/your machine
  • Reimport the site back into Local. You can refer here on how to Restore from only Local site files