Can't get ANY sites working on BigSur -

Issue Summary

Admin shows " Not Found. The requested URL was not found on this server." Open Site shows “It Works”. Tried both Router methods, neither work.

Troubleshooting Questions

Happens to all Local sites
Can’t create any new sites, same issues.
Tried both Router methods, neither work.


All sites dont work

System Details

  • Which version of Local is being used?
    MacOS Big Sur 11.2.1

  • Attach the Local Log.

local-lightning.log (154.5 KB)

Go to your database to options table and see the records for siteurl and home. See if they are correct. Did you import your database from another website? If so, did you modify your wp-admin path there to something custom? If you did, did you import your .htaccess file which points to the correct location? Because without that it won’t work.

This issue still happens with any new site that I create though?

Try restarting your Mac.

Thanks @afragen,

Thats worked, I am now able to access pages if I use the localhost method! But, I still cant access using the site domain method. Any ideas how to fix that one?

I assume you’ve set Advanced > Router Mode to Site Domains.
Do you have a log for the errors or an error log?

Yep, that option is set.
When I change it to Site Domain, I get this warning “There is a port conflict with this sites domain”
nginx error log attached.
error.log (30.8 KB)

How about local.log?

Maybe quit Local, restart Mac after the change to Site Domains?

local-lightning.log (193.6 KB)

I think I tried that but it didnt work, maybe I’ll try again…

The following command should kill all nginx/httpd processes.

lsof -i | grep LISTEN | grep "nginx\|httpd" | awk "{print $2}" | xargs -n 1 kill

Might want to try that after quitting Local.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.