Port conflict with this site’s domain

I’ve tried following the steps in Resolving: Port conflict with this site's domain, but still get port conflict errors regularly in Big Sur with LocalWP 5.9.9.

Even after quitting the app, I’m still seeing these two processes running on port 80:

nginx 88139 scottbuscemi 11u IPv4 0x58d7c90cc4b23e19 0t0 TCP *:http (LISTEN)
nginx 88139 scottbuscemi 12u IPv6 0x58d7c90cc859fd29 0t0 TCP *:http (LISTEN)

88139 ?? 0:01.22 nginx: worker process

The domains still work, but the port conflict notice keeps popping up regularly after starting a site. This happens with multiple sites.

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?
    macOS 11.2.1

I see this too. I’m not sure what’s triggering it but all the sites still function even when I ignore the notice.

1 Like

In Big Sur 11.2, I’m on Local 5.9.9, just re-installed yesterday. Every time I reboot and start a site, I get a port conflict message as well. I see the 502 Gateway error.

I open terminal and run the suggested command. Kill the process running as root for nginx, using the suggested command on the help page you mentioned. There are several other running on port 80, but with my user account.

After that, the site will run after I restart it in Local. Pretty annoying to kill that task every time. I couldn’t find any clues as to why that task is running and how to start it at startup.

MAMP was installed, but I used AppCleaner to remove it. Is it the Local.app running on port 80 or some other MacOS process.

1 Like

It’s likely the Local app’s router that is listening on port 80 and when Local quits it isn’t cleaning up those processes.

I haven’t updated to Big Sur (on Catalina, mostly because IT says I need to :sob:)

But you’ll usually see a number of processes on port 80 related to Local’s router.

sudo lsof -i:80; sudo lsof -tnP -i:80 | xargs -n 1 ps -p

Local seems to be quite a mess right now on Big Sur, to be honest :confused:

  • Stopping sites still doesn’t work 50% of the time (requires an app restart)
  • Port conflicts
  • Checking for an app update shows nothing
  • Even when xDebug isn’t running, pages take 10 seconds to load if it’s installed on the site (maybe related to these port conflicts?)

In my case, the port conflict occurs always after a fresh reboot, when starting the first site of the day. Once the master process is killed, it seems to work normally until I reboot.

Maybe Local is conflicted with itself? :laughing:

The workaround, for now, will have to do.


Same problem here.

Mac OS 11.2.2
Local Version 5.10.0+5257

Hey everyone, thanks for your patience with this! There was a regression related to this port conflict in the 5.10.0 version of Local.

We released 5.10.1 as a quickfix version – can you install that and let us know if you are still experiencing the issues with Local conflicting with itself on port 80?

Just downloaded since the Check for Updates feature still is borked.

The port issue was happening back in 5.9.9 - does the quickfix resolve what was happening back then or only what was broken in 5.10.0?

The specific issue that the 5.10.1 fix addresses was Local not cleanly killing the Router process. This is the process that listens on Ports 80/443 and which directs a request to the individual WordPress site.

Are you still seeing a port-conflict issue on your machine @scottbuscemi?

I’m on 5.10.1+5267 and I’m still seeing a port conflict alert. Everything seems to be running fine, though, aside from the alert and suggestion to use localhost.

Same. Just happened to me when I moved from php 7.4 -> php 8.0 for a site.

Curious if this is also what’s causing my sites to run slow even when xDebug isn’t actively running. I’d expect page speeds to be slow when xDebug is active, but it will still take 8-10 seconds/page even when xDebug isn’t running now.

I installed the update a few days ago and restarted my computer. I have not seen the port conflict message since doing so.

Mac OS 11.2.2
Local Version 5.10.1+5267

Getting port conflict all the time when my sites are running now. On the latest version of Local + macOS 11.2.3. @ben.turner

We’ve noticed that there are some differences in behavior between BigSur on Intel hardware and BigSur on M1.

@scottbuscemi – do you have a new M1 mac, or are you using an older Intel based system?

Big Sur + M1. Always happy to help troubleshoot. @ben.turner

1 Like

Same happens here. Local on iMac with Inter processer + Big Sur works well but on my M1+Big Sur combo threre is a port conflict here and there, which means that Local is basically unusable.

I see this too on M1 Mac but it doesn’t seem to have any effect. Everything still works as well expected for me.

1 Like

Is there any resolution to this problem?

Running Local 5.10.3+5332 on macOS Big Sur 11.2.3 (20D91).

M1 chip machine.

Is it actually affecting you? For me, it shows the alert banner but doesn’t affect usage.