Can't import zip from same version of Local

What issue or error are you experiencing?

Cannot import a site that was just exported from the same version of Local ( 8.3.2+6660 ). On the old source computer, started up the site in Local and exported a zip. Transferred that to the new target computer, ran the import and get an error “Please try again with a compatible ZIP file.”

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version: 8.3.2+6660

  • Operating System (OS) and OS version: Target = 14.4.1 (23E224) Source = 13.3

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log) (7.9 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Have tried with multiple different zips of multiple sites, same results every time : (

Hi @alexwright

Can you try opening up the zip file and then importing the site manually using the steps here?

Manually Import a Local Site

Thanks, Nick. I tried that but it’s quite cumbersome and involves more steps than I’m looking for. I ended up downloading a zip directly from Kinsta. That imported okay. Do you know why it is that a working site exported from Local won’t import on another computer running Local? Seems to defeat the purpose of easy Local to Local transfers.

1 Like

Hi @alexwright

It is tough to say without being able to view and test your site, but I’m glad you were able to get it going with a workaround!

As a sort of middle ground, you could also try opening up the zip export, reducing it down to just the WP-Content and MySQL files, and then zipping it back up to see if that imports.

Some things we’ve seen in the past that will cause these sorts of “incompatible zip file” error:

  • Extra full site backup files
  • Extra DB backups
  • Altered/customized WordPress core files
  • Plugin conflicts
  • Bloated DB tables
1 Like

Thanks @Nick-B for your reply! I don’t see any of those being issues. These are all sites that run just fine on Local, WP Engine and Kinsta. They’re pretty little! I did try removing everything but wp-content and the sql file, but my Mac didn’t like re-zipping them due to a permissions issue. I couldn’t find any locked files, though.

Can I send you one of the zip files exported from Local? I have a dozen or so similar sites to transfer and I’m dreading doing all of this manually.

If you have a lot of sites to move as another workaround you could try using our Cloud Backups Add On. You can backup the site on Machine A and then pull it down on Machine B.

Cloud Backups

Can you expand a bit more on the permissions issue blocking you from rezipping a site?

Have you been able to replicate this with multiple sites so far or has it been just this first site having problems?

I am not able to import any sites from one computer running Local to another computer running Local. It is so incredibly frustrating. I appreciate the Cloud Backup links but that isn’t what I am looking for. I want to export a totally working Local site on one computer running the exact same version of Local to another computer running the exact same version of Local. I have tried this on ~10 different websites and all of them fail. Can I send you copies of the zip file exported from Local? Why won’t that file import to another comptuer running Local? Seems like a no-brainer.

Hi there @alexwright -

How are you creating the exported site in Local? Just with right-click “Export”?


@sambrockway Yes, starting the site then exporting it by right clicking and selecting export then transferring that to another version of Local where it errors out on the import saying the ZIP isn’t compatible.

I tried using the whole workaround to backup to Dropbox but the issue there is that when creating a site from a backup, you can’t select a local domain or location. It defaults to the Local Sites directory which has a space character and that’s super annoying. Even though I’ve changed my default install location to Sites, the import from backup automagically defaults to Local Sites and a default web address, none of which is what I need.

I love that you all work so hard on this and I imagine WP Engine doesn’t really fund this project but it is mind blowing that it is so hard to transfer a working Local install between two computers running the exact same version of the same software.

Hey @alexwright - thanks for helping us troubleshoot this one.

To start, you’re right - exporting and importing sites from Local to Local should be seamless. Based on your logs, it looks like this is specific to the site/theme somehow.

Here’s the error where the import fails:

{“level”:“warn”,“message”:“Unable to import site.”,“stack”:"Error: ENOENT: no such file or directory, mkdir '/private/var/folders/b_/31_0zpyj76n1ylvr2881jkp80000gn/T/local-by-flywheel-bVeGs50MkB/app/public/wp-content/themes/level-bs-4/node_modules/puppeteer/.local-chromium/mac-722234/chrome-mac/ Framework.framework/

The error is specific to the level-bs-4 theme. Is that something you’re developing?

Potential short-term fix:

  1. Removing the nodel_modules directory before exporting could allow the import to succeed

I’d love to take a look at the .zip file - you should be able to DM it to me and we can take a look!

Thanks, @austinwendt. I really do appreciate the time you spent going through the logs.

The message you quoted doesn’t seem like a reason to fully cancel an import. An empty file or directory seems like it’s not a reason to cancel the whole thing. Yes we use node for theme development so there’s a lot in the node_modules and I could see that some of those directories and files may be empty.

I’m trying to figure out now if this has to to with either / both node_modules or .git directories and contents. Some combination of those are (were) barfing out the zip export.

Sadly, at this point, the (dying) computer I was trying to export the installs from has fully died so there is no more chance to export a ZIP. I was able to push all installs to the Dropbox backup function and I can start pulling those. I don’t know if they contain or strip out .git or node_modules directories.

I appreciate your efforts and customer service. Local is a way better product than DevKinsta and I still use it even though most of my sites are no longer on WP Engine.


Fair point - that’s something we can look at improving in how we handle those empty/missing directories.

Just linking for future readers - here’s another forums post where a user goes into detail about excluding node_modules from exports - Exclude folders from export

:slightly_frowning_face: Sorry about the dead computer, that’s a bummer. If you continue to have any issues, just let us know - and if so, happy to take a look at the files. We’re glad to have you still using Local, I’ll pass the kind feedback onto the team :green_heart:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.