Can't Open Local

Issue Summary

I’ve had Local installed and running well for a year or so. Now it won’t open. When I try to open it, the mouse cursor changes to the processing icon for a second or two then changes back to the usual cursor. Task Manager shows 3 instances of Local (32 bit) running. But Local isn’t visible at all. There are no error messages. Tried reinstalling and rebooting but it didn’t make any difference

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used? Windows 10 Pro

  • Attach the Local Log.
    local-lightning-verbose.log (5.5 KB)

Hey @Pixie – Welcome to the Local Community Forums!

The error in the Local log seems to point to a permissions issue:

{"thread":"main","errno":-4048,"syscall":"open","code":"EPERM","path":"%%userDataPath%%\\settings-new-site-defaults.json","level":"error","stack":"Error: EPERM: operation not permitted, open '%%userDataPath%%\\settings-new-site-defaults.json'\n    at Object.openSync (fs.js:476:3)\n    at Object.func [as openSync] (electron/js2c/asar_bundle.js:5:1846)\n    at Object.writeFileSync (fs.js:1467:35)\n    at Object.writeFileSync (%%appPath%%\\node_modules\\jsonfile\\index.js:117:13)\n    at Object.outputJsonSync (%%appPath%%\\node_modules\\fs-extra\\lib\\json\\output-json-sync.js:15:12)\n    at Function.set (%%appPath%%\\main\\app\\UserData.js:1:654)\n    at Function.stripWpCredentialsFromSiteDefaults (%%appPath%%\\main\\app\\dataUpgrader.js:1:570)\n    at Function.runUpgrades (%%appPath%%\\main\\app\\dataUpgrader.js:1:325)\n    at Object.<anonymous> (%%appPath%%\\main\\main.js:1:4660)\n    at Module._compile (internal/modules/cjs/loader.js:1078:30)","message":"EPERM: operation not permitted, open '%%userDataPath%%\\settings-new-site-defaults.json'","timestamp":"2022-01-13T18:18:32.600Z"}

Was there a recent change to the operating system? Something like an update that might have change the permissions on the home folder?

You might try uninstalling Local and re-installing it so that those configuration settings are set correctly. This help doc goes into more detail about uninstalling the various parts of Local:

Thanks, that worked

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.