Can't pull sites from flywheel

What issue or error are you experiencing?

I can’t pull sites, they all get to about 4mb from completing then stall indefinitely, I’ve totally uninstalled and reinstalled the latest version of local, same issue, prior to this, local also would not update, I had to delete it and download the update from the site directly anytime i needed to update as the updates also behave the same, stopping with around 10mb left indefinitely

I have plenty of space on my hard drives so thats not it, this has been ongoing for several releases now, I reached out once before but got no response

This needs to be sorted


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

See below, just trying to pull any site from our flywheel happens on every single one, regardless of size or site specifics


System Details

  • Local Version:

Version 8.2.1+6583

  • Operating System (OS) and OS version:

Macbook Air M2
Sonoma 14.2.1


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

local-lightning.log (26.0 KB)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @hmdg

Have you contacted Flywheel support to see if they can replicate the problem?

Are you using a VPN or office network when you test?

If you download a backup, and direct import that into Local does that work?

I was told to contact local as the issue is there and flywheel don’t offer support for local so to open a ticket here?

No firewall, no VPN

Hi @hmdg

I have access to all things on the Flywheel side and tried looking but I didn’t see any recent chats or tickets with you regarding Local, at least under your current email.

I’m happy to help you further but may need to DM you for some more specific details for testing so that we don’t share any of your info in this public forum.

Before we get to that though were you able to try the workaround? Are you able to download a backup and direct import that into Local for a site that isn’t connecting?

just tried one now and I’m able to download a backup and import it, that just obviously takes a fair bit longer, so if we can figure out how to get local working with pulls again that would be preferable

Not sure why you couldn’t see my chat, it was some time ago now so you may have to go back a bit, this has been ongoing for a while I just opened this new ticket here as it is still happening

I’m glad you’re able to download and backup as a workaround! It does take more time, but it’s nice to have as an alternative. It also helps to narrow down where the issue is.

Are you using the Apple Silicon version of Local on your M2?

Also, do we have permission to test connecting and pulling any of the sites under your associated email on Flywheel?

hey Nick

Yup the apple silicon version is what I’ve downloaded and installed, again please note that I wasn’t even able to update Local when it needs an update, and instead each time I have to fully uninstall it, download the whole thing new from local again, and reinstall then manually re-add any sites i was working on each time

So the issue definitely appears to be with local finishing / connecting remotely to your / flywheels servers from my end?

Not sure if that helps

Yes you have permission

Do you have Rosetta installed?

Rosetta 2 is required for Local’s Apple Silicon build due to the Nginx and MySQL Lighting Services compiled on the Intel architecture. We do plan to have a Local release out in the future that will drop this dependency but for now it is necessary.

You can install Rosetta by opening up a terminal window and using this command:

softwareupdate --install-rosetta

Others have found this doc to be helpful: