Can't upload images

Issue Summary

I’m not able to upload images and I receive a “The server cannot process the image. This can happen if the server is busy or does not have enough resources to complete the task. Uploading a smaller image may help. Suggested maximum size is 2560 pixels.” error message. I even tried to put the image in the folder and it’s not showing up. I’m also missing 3 additional images that I see in the uploads folder.

Image is less than the 2560px and is only 500kb. This was an imported site from another machine that was running Windows 10 and my current machine runs Windows 11.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    All sites.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?


Every time…same thing. Whether it’s drag and drop to upload or browser upload.

System Details

  • Which version of Local is being used?
    Most recent.

  • What Operating System (OS) and OS version is being used?
    Windows 11

  • Attach the Local Log. See this Help Doc for instructions on how to do so:
    site-error.log (12.1 KB)

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

So it seems the issue is with using Apache instead of Nginx. Wish I could provide more info, but after I switched to Nginx, even with a new site added, uploading images work.

1 Like

Yes, this was also the problem for me, it got solved by switching to Ngix. Thanx

I have exactly the same problem, but only with .png files, .jpeg uploads as expected…


  • Windows 10 64 bit
  • Local 6.4.1
  • I setup folder for Local Sites on another drive (D), other than Local app (C)

Switching to Nginx works, but is a workaround, not a solution…
Still need help!

The same issue when I tried to upload any image, even if it´s smaller than 2560px, using Apache. When I change to nginx the problem has gone. Someone can help?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.