Can't view site locally

I connected Local Flywheel to my account, added a local site. The app ran, the site said that it was running but I was unable to access it.

I confirmed that MAMP was not running and that my host file had the proper entries and still had no luck.

I rebooted and now the site seems to be stuck in the started process.

The app says that I am connected but I am unable to pull the code.

Looking at the site content the site folder seems to be empty.

Any help would be appreciated.


Hi Adam,

Sorry for the trouble!

Does this happen if you create a brand new site using the plus button in the bottom-left?


A new local site worked fine. It took maybe 30 seconds to make as well.

Very fast.

It also worked while MAMP was running

That’s good news!

The partially bad news is it sounds like the import from the pull failed for some reason. The best way to look into this is for you to provide your local-by-flywheel.log file. If you’re on macOS you can go to Help » Reveal Local’s Log and then provide the file here.

Here is the log file.

local-by-flywheel.log (44.3 KB)

I think part of the problem had to do with the size of the site,

This site is 11 gigs.

I managed to get it to work but after adding a few small changes the resin took a few hours.

are there any plans to have a change log that syncs or possible hot link wp-content?

It is totally unpractical to sync 11 gigs.

Adam Patterson

Glad you got it!

I totally agree. We’re currently looking into various technologies to handle differential syncing.