Checking site Compatibility is spinning

I would like to push a local site to flywheel but the Checking Site Compatibility is just spinning and never stops. I’ve restarted the site and local without success. Help?

So I disconnected the site in Local, then clicked push to Flywheel on the site again, selected the site in Flywheel on the dropdown and I got this error…"We ran into an issue pushing to Flywheel.

If this problem persists please contact"

I am having this same issue.

@shineforth @ryanmitchell,

Can you both provide your local-by-flywheel.log files?

Also, was Connect to Flywheel working for you both prior to this morning?

Here you go. I tired to connect around 1:30 MST

local-by-flywheel.log (488 KB)


I’m not seeing anything helpful in the log for this issue.

Can you private message me the site domain that you’re having trouble with? From there, I’ll pass it onto our platform team and they can take a closer look into it from our end.


Got it, thanks!

I’ve passed this along to the Flywheel Core team.

I backed up my local site then tired to create a new site in local pulling down from Flywheel. Got an error. Figured I would provide the log that may have an error.

local-by-flywheel.log (551.6 KB)

It seems like I only have this issue on one of my sites. It was working yesterday morning but then stopped working. It’s not an issue on at least one of my other local site. It’s still spinning today though.

I just noticed that the site now shows connected to Flywheel. The only thing I’ve done is push another site to Flywheel while I had this one stopped. Either that cleared something up or Flywheel made a change/fix on their end?

Our Flywheel Core team made some adjustments late night. Is it still working fine for you this morning?

Yep it’s working now.

1 Like

Having the same issue today, won’t stop spinning! Is there anything I have to do to fix this?

local-by-flywheel.log (108.5 KB)

Hi Natasha,

Sorry for the delay! Based off of the log it might be related to an authentication issue.

If you’re still having this problem, please try the following:

  1. Go to the main Connect to Flywheel page in Local
  2. Click on your avatar in the top-right and click the option to sign out
  3. Reconnect Local with Flywheel once the button appears
  4. Check the site page in Local

Now it works! Thanks!

1 Like

I’m also getting this same issue. I’ve logged out of Local a whole bunch of times, even deleted the site on Flywheel and created a new one through Local. I still get the forever spinning ‘Checking Site Compatibility’ popup.
local-by-flywheel.log (558.5 KB)

Hi @CPN,

Please upgrade to Local 2.3.2 or newer (2.3.2 is the newest at the time of writing this).