Push to Flywheel: Site never finishes checking compatibility

I’ve pushed and pulled sites from Flywheel a lot, and for whatever reason I have one that gets stuck on “Checking Compatibility” and never pushes.

Is there anything you can think of off hand?

  • It’s using the Preferred 1.1 environment
  • This site has previously pushed to flywheel, but that site was removed at one time. I’m trying to link it up with a different Flywheel instance (but it is not linked and I never make it to the part of the interface where I make that selection)
  • It does have tables with several different prefixes in the database, if that makes a difference
  • The site is working normally otherwise

Hey Jon,

There are two solutions:

  1. Upgrade to Local 2.3.2
  2. Edit the sites.json file
    1. Navigate to ~/Library/Application Support/Local by Flywheel/sites.json (macOS)
    2. Open the file
    3. Remove flywheelConnect from the site that is having issues. Validate the JSON and then save.
    4. Re-open Local

Awesome. I’ll try that and get back to you.

Very odd. So, it worked!

I installed the new version, it wasn’t detecting WordPress, then I reset that line in the json file and it pushed.

However, when it pushed, I got a 502 error. I tried pushing a second time. I see the database there, I see the files there – but the wp-config file appears to be missing, which is weird.

I see this:

Sorry, I need a wp-config-sample.php file to work from. Please re-upload this file to your WordPress installation.

I see the wp-config sample file locally, so I’m not sure what to do next.

Looks like that was a separate issue, and is resolved. Thanks again, Clay! Always appreciate the help!

1 Like