Local Community

Cloud Backups not working for Google Workspace?

Hi there,

I’m planning to migrate my workflow from Dropbox to Drive on Google Workspace and I just noticed that the Add or Manage Provider option is not working for this type of account:

I can see Dropbox as linked service both on the local app and in the browser.

If I go through the step to authorize Drive everything works fine, I even get the “Cloud Backups is connected to your Google Drive account. Open Local to back up a site” message. But nothing happen then. In the browser I still get the “Connect” button and no Drive is listed as option in the local app.

Tried the same steps with a free @gmail account and it worked smoothly at the first attempt.

Cloud Backups should work with Google Workspaces. Typically if there was an issue, Google would respond with a 400 error if there was a setting on the workspace that prevented the connection from happening.

Out of curiosity – are you using the same email for both accounts? For example, did you sign up for dropbox using your Google email?

I wonder if there’s a bug here where the Local account is being confused with the same email being used.

If that is the case, then can you try disconnecting from Dropbox and then connecting with Google Drive?

Oddly it’s the way back: the standard Drive account share the same email as user ID with dropbox and works fine. The Workspace one have a different email and it’s the one not working.

Tried again on a different machine with a different browser but I got the same behavior.
I’m on a Business Standard plan.

In the next days I’ll try to disconnect dropbox and repeat all the steps.

Tried with another Google Work account: same result ¯_(ツ)_/¯

Ahh, that’s interesting. Just so I’m sure I’m following, does this roughly look like what’s going on?

  • Personal email (and drive) mypersonalemail@gmail.com
  • Dropbox user id: mypersonalemail@gmail.com
  • Work email (and drive) me@myagency.com

Using the example above, if you try and connect to Google Drive with mypersonalemail@gmail.com – does Cloud Backups connect successfully?

In your testing, did you try disconnecting from Dropbox?

Exactly. Only the standard gmail accounts seems to work, no gwork account working so far (I just tried with a third one just now).

Unfortunately not yet. I discovered the issue because I was in need of the backup in my worflow right now and I’ll need it for another couple of days. I tried to add the Gwork account I’ll migrate to before march just to start moving my files away from Dropbox and encountered the problem. As soon as I’ll be free to unlink dropbox without disrupting the project workflow I’m in right now I’ll give you more feedback.

Another info (sorry if I can’t be more useful, I know it could be a nightmare debug issues like that): oAuth consent work just fine for other application such as Transmit or Commander One: they get all they need to mount Gwork Drive as a volume on my filesystem. That should probably exclude as culprit some settings in admin.google.com for those accounts.

1 Like

Woah. That was odd: It just come to my mind that in the past I used to log in to hub.local.wp with both my github account and my personal gmail account.

Once I got to my account page and disconnected the personal mail from the section Accounts for logging in it started to work, tried in the Local desktop app too.

That was the behaviour:

  1. Unlinked personal@gmail.com in the main localwp account tab.
  2. Moving to the Cloud Backups tab then I was already logged as me@work3.com
  3. Clicked on Disconnect > updated automatically showing me logged as me@work2.com
  4. Clicked on Disconnect again > updated automatically showing me as me@work1.com

So in the end looks like the oAuth tools was acting correctly but with a hierarchy underneath like that:

  1. Main account over plugin account (but nothing showing as connected in the plugin tab without explicitly using the same account here too)
  2. last oAuth over past oAuth

Sorry not having thinked it earlier (I mostly forgot having used the Google social login in the first place) but now it makes sense at least!
\0/