Constant cURL errors when installing or updating Themes, Plugins

I read similar topics but I am facing the same problem at both my PC and Laptop where I did the following:

  1. I restarted Local Machine 5-6 times —> on PC I manage to update one plugin after restating but I could not update the rest of my plugins, Theme and WP to 4.8.1. On Laptop nothing changed

  2. I restarted my PC and my Laptop. Then I checked for outdated drivers and installed the new ones —> nothing changed, I still get constant cURL errors

  3. I deleted everything from Local Flywheel and re-installed it —>Nothing changed…still getting errors

I run WP multisites in Apache server, No SSL, Latest MSQL. Both my PC and Laptop run Windows 10.
The cURL error message is always the same "28…after 10525-10530 milliseconds …

Please Help!

I am still waiting for an answer.
Please help!
I have 8 websites on Local Flywheel and because of the constant cURL errors I cannot even move them…If the Flywheel community cannot help on these technical matters then where else can I ask for help???

You might try referring to this, Timeouts during nginx xdebug session

You will have to have a Custom, not Preferred, installation.

Hello afragen!
Thank you for your reply.
Unfortunately your tip didn’t resolve my problem. I changed the timeout to 6000 (apache2.conf), I restarted Flywheel and I experience the same cURL errors. I Cannot perform ANY update, installation, or any Site move (with Duplicator plugin) without having cURL errors. I 've also changed all the limits (memory limit, input vars…)…nothing. I have constant errors after the last update of Flywheel.
All of my installations on Flywheel as follows:
PHP Version = 7.0.3
SERVER = Apache
MySQL - 5.6.34
What bothers me is that there is no support from flywheel. This is the main reason I will move everything back to Wamp.this will take me some hours of work but…I cannot think other solution…

Thank you very much for you help!

Hi @LUSH-IM,

Sorry for the trouble!

Chances are, this is a DNS issue with Docker. To get this resolved, I need you run a few commands to gather some more information.

  1. Right-click on any running site in Local and go to"Open Site SSH"
  2. After the terminal opens up, enter cat /etc/resolv.conf and provide the output here
  3. Run ping google.com and provide the output here

After gathering that information, you can try the following as a temporary solution:

  1. Run nano /etc/resolv.conf in the site container SSH
  2. Change the nameserver line to
    nameserver 8.8.8.8
    nameserver 8.8.4.4
  3. Restart the site in Local

I am in the same position as you; I now have to move this back to MAMP because it’s impossible to work with Flywheel, they rush to release an update, which screws things up, cause I never had this problem before the latest update. Too bad they don’t test their updates before screw with our workflow. This is nowhere close to what it is advertised.

Here are my information: https://www.dropbox.com/s/hl9vqcpfes39b2x/Screenshot%202017-08-19%2014.30.03.png?dl=0

I did put the new name servers in /etc/resolv.conf file but if I do a restart of the website, I get the old values. Also when I press CTRL + S to save the file I get https://www.dropbox.com/s/483obzyaybs6trh/Screenshot%202017-08-19%2014.41.50.png?dl=0.

I have to press CTRL + X and then it asks me if I want to save the file, I choose Y and then it asks me the name of the file, I keep the same name.

What is the next step?

Hello Clay,
I am so sorry to see your response to my topic after so many days!
I had to continue working on my local sites in order to meet my deadlines, so I painfully moved them all from Flywheel back to WAMP.
I am sorry to tell you again how disappointing is the Local Flywheel support. I used your application for professional projects because, at first it sounded very promising. But your support, unfortunately didn’t meet my professional expectations.
I wish you better support and updates for the future.

@ueduard1982,

Can you please try the steps in this post? Warning: An unexpected error occurred


@LUSH-IM

Sorry to hear! Right now Local support is forum-only since it’s a free product.

As soon as Local Pro is released we will provide e-mail and chat support for Local :slight_smile: