Local Community

Copy my unzip plugin files into plugins folder


I am trying to copy all of my plugins into plugins folder however whenever i go and check through my dashboard it says no plugin is there. How can i make it work without uploading any plugins?

Hey @salmanaziz Welcome to the Local Community Forums!

I’m a little confused by this feature request – are you asking for a feature of Local to be to automatically unzip and install WordPress plugins so that you don’t have to use the WordPress admin?

You should be able to unzip those zip files within the plugins folder using whatever unzipping tool the operating system uses.

Once that’s done, those plugins should show up in the WordPress Admin.

1 Like

Hi Ben,
Thank you for your reply. Exactly the same as you said. I just unzip my plugin into plugin folder but in the dashboard i am unable to see any but when i check the folder my plugins are there. i do not know what i am doing wrong. It should be visible in my dashboard right?

You’ll need to unzip the plugin first. Usually that means copying the zip file into the wp-content/plugins folder and then unzipping it so that it’s one folder.

One common problem that I see when doing this for premium plugins or themes (like from Envato) is that the plugin zip that you get from them, actually contains other things besides just the WordPress plugin. This could be things like bundled Photoshop files, or other assets that don’t make sense within the code for a WP plugin.

In that case, you’ll need to keep opening folders and finding the specific WordPress plugin, and then unzip that directly into the wp-content/plugins folder.

Hi ben,

I tried that and pasted all my unzip plugins inside but i am unable to see it when checking through my dashboard. So to check i tried to install one plugin directly and i got the error .

Installation failed: Download failed. cURL error 60: SSL certificate problem: self signed certificate in certificate chain

However i have installed SSL as well.

Also if i go in my dashboard settings.php page there is an error as well, mentioned below.

Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server&#8217;s configuration. If you continue to have problems, please try the <a href="https://wordpress.org/support/forums/">support forums</a>. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in C:\Users\v-salman\Local Sites\localsite\app\public\wp-admin\includes\translation-install.php on line *68*
Call Stack
# Time Memory Function Location
1 0.0008 419760 {main}( ) ...\options-general.php**:**0
2 0.2054 3723080 wp_get_available_translations( ) ...\options-general.php**:**159
3 0.2060 3723952 translations_api( ) ...\translation-install.php**:**133
4 0.7835 3812792 [trigger_error](http://www.php.net/function.trigger-error) ( ) ...\translation-install.php**:**68

Local already does allow for plugins to automatically be available when they are within the wp-content/plugins folder, it looks like you might be experiencing a specific issue with this specific machine. Because of that, I’m moving this topic from the “Feature Requests” category into the “Support” category.

I think that might refer to some outdated certificates within the computer’s certificate chain. You might take a look at this topic where the user solved a similar issue by downloading and referencing a more up-to-date collection of those certificates:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.