Correct way to import a site that sits in a subdir?

Result last week under 5.2.4 was success.
Now, under 5.2.5+2498 is 404 for both “Admin” and “View Site.”

My live site sits in a subdir: All WP contents are in the /blog subdir and the siteurl in the db is

My practice is to download the live site from a VaultPress backup, unpack the .tar. repack the parts in a .zip and import. No edits, renaming or moves along the way.

For various versions of local, I’ve needed to edit .htaccess to remove all blog/ references (about 15), or change the sitrurl in the wp_options table. Last week’s experience with 5.2.4 required neither of those (cheers!) This week, with 5.2.5+2498 all I can achieve are 404s. I’ve tried both the .htaccess edits and the siteurl edit. Neither worked. Nor, did removing .htacecess altogether.

In addition, Adminer access to the DB fails with the “None of the supported extensions…” message. (Another thing that was working OK with 5.2.4.)

All this on Windows 10.



I no longer care about this problem. Being frustrated with things working in one version and not working in the next, I’m moving to Laragon.

THANKS to all the helpful folks in the Local community.