Database not updating when making site changes

Hi all, i’ve got a strange issue where Database changes aren’t saving, things such as adding Pages, Posts, Formidable entries, is as if local changes aren’t be written to the database at all, alos effects Media Uploads and attaching Featured Images, i’ve tried reinstalling Local, i’ve tried re-importing sites, exporting and re-importing databases all seem to have no change, it seems to be quite erratic as to when it happens.

Anyone else had this issue?

Hey @pixelsandthings,

Did you check every linkage from your environment to the database?

Possible checks to make (from the back of my head haha):

  • Check database constants (DB_NAME, DB_HOST, etc) on wp-config.php
  • Check $table_prefix variable on wp-config.php
  • Check if your site makes any connections to an external database

Apart from those, would be good to look for any errors and the database itself.
So you can open the database from local with Adminer or Sequel Pro (if on Mac) and see if your database matches the info you saw above on the checks you made.
Also look for errors on php and apache/nginx, in Local’s logs… There might be something useful there for you to better filter the reason for your problem.

If you need further help, I’ll be here! :wink: