EACCES error after moving volume on Mac

I’ve recently changed my hard drive, manually moved all my ‘Local sites’ over and now Local doesn’t work. It can see my site list, but can’t launch anything without this error:

Error: EACCES: permission denied, mkdir ‘/Volumes/Samsung 2023’
Screenshot 2024-04-24 at 09.29.00

I"ve added the new location correctly but I still get the same error.

What am I doing wrong? Can someone guide me?


System Details

  • Local Version:
    Version 9.0.1+6673

  • Operating System (OS) and OS version:
    macOS 14.4.1

Local Logs

local-logs.zip (18.6 MB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @markmapstone

It looks like you’re trying to use an alternative site path that Local might not have access or permission for. Did you change the path manually? Does it have open permissions or could there be any other security features in the way?

Yes, I’m using a different path. The old Samsung 2023 volume was working fine until a new drive upgrade to ‘files2024’. I copied all my ‘Local Sites’ files over to the new drive and changed the site path in the LocalWP settings to the files2024 drive as shown. I assumed it would just work, but no. Local does have access to my removable volumes in my mac Settings > Privacy & Security area. Any ideas what I should try next?


Are you able to create a new, blank site without getting any errors?

If it’s only your previously created sites getting the errors then you might need to reimport them to get things re-syned.

Restore from only Local site files

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.