Local Community

💥MY LOCALWP CRUSHED! Uncaught Exception: Error: EACCES - What can I do? Please

Issue Summary

Hi there! I unistalled my local wp after some problems about a 404 error. I installed from zero after this and crushed so crazy!

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

My Local WP doesn’t run. This is the exact issue:
Captura de pantalla 2021-06-08 a las 3.50.58

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    Sorry but I’m not able to.

Replication

Sorry but I don’t know exactly which was my way to land here particularly during the uninstallling. I honestly think that I touched (erased) something that I must not.

System Details

  • Which version of Local is being used?

5.10.5 is the version that I tried to install.

  • What Operating System (OS) and OS version is being used?

    • macOS High Sierra 10.13.6
  • Attach the Local Log. See this Community Forum post for instructions on how to do so:
    Sorry but I have any log. The only one that I could show is from before: error.log (974 Bytes)

the EACCES: permission denied error means that for whatever reason, Local isn’t able to open a file that it needs to open.

Since you’ve uninstalled Local, you might try completely removing Local’s configuration folder and then re-install Local.

For reference, that configuration folder is located at:

~/Library/Application Support/Local

Can you try quitting Local, deleting that folder, and then re-install Local?

The only other thing that stands out to me is that it seems that the OS is High Sierra, which I’m unsure if that works on the latest version of Local since we focus our testing on the most recent versions of operating systems.

Ok, I’ll try it and ley you know.

Thank you so much Ben.
Kind regards.

Hi there!

Thank you so much for your answer. I was repeated the process of reinstall once and once again but not this way and It worked.
It was perfect but I’m so sorry to tell you that I have the same problem that made me unistall the first time. All the site projects are landing in a page that says “It works!” and the admin page left me a 404.

I attached also the routers error.log:
error.log (985 Bytes)

I made a backup of my Local sites because there were some projects not finished yet and even these are recognized like 404 like I mentioned and keep the new installation with a prove site in order to try some new ways to resolve it.

[After touching a little bit more I think is a good idea attach the local-lightning.log to help you to know what is happening] local-lightning.log (288.8 KB)

[Edited some hours later] _ I found this

and don’t know why is trying to work in this port (10003) and not the 80.

I apologize if my explanation is not the best, do you think that’s a way to solve it?
Thanks for your support Ben :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hey @isma -

This is how Local works. Each WordPress site’s server process (Apache, or Nginx) listens on a specific port (like 10003). There is also a process called the “Local Router” that is an Nginx process listening on port 80, which proxies all of those other ports, and allows you to access each site with a meaningful domain.

The main thing I notice when looking at those screenshots is that the 404 page is so plain looking. That makes me think that some other Apache process (ie, not Local’s router process) is listening on port 80.

You’ll either need to figure out what apache process is listening on port 80 and stop it so that Local’s Router can use that port, or make Local use the localhost Router Mode setting under “Preferences > Advanced.”

For more info on this setting as well as this general issue, see this help doc: