Elementor and SSL issues under Windows

I’m unable to update from 5.8 to 5.8.1 - but I just set up a 2nd site and that automatically set up as 5.8.1

Elementor updates fine - but why the error on WP?

Cracked it - I wasn’t logged in to the Local account
Login via the ‘Local App’ portal and the update worked.

This seems odd to me. I don’t think you would need to be logged into your Local account to update to the latest version of WordPress.

Maybe there was a cached value somewhere that was causing issues? Either way, if you encounter this again, I’d be curious to see what the Local log and the PHP error log look like for the site.

Thanks for coming back Ben - I haven’t any alerts so I didn’t see this.
I looked for the php log for the site, but the folder is empty!

I came back for a different problem - but maybe there is a similar cause - the pages I create in elementor do not flow to be uploaded when I “open site” from the ‘local dashboard’.

I can fing a log in my Elementor site settings: PHP: showing 1 of 1
PHP: 2021-10-13 14:03:46 [notice X 2][C:\Users\User\Local Sites\pmv\app\public\wp-content\plugins\elementor\core\common\modules\ajax\module.php::171] Undefined index: data [array (
‘trace’ => ’
#0: Elementor\Core\Logger\Manager → shutdown()
JS: showing 1 of 1
JS: 2021-10-13 16:30:17 [error X 9][http://pmv.local/wp-content/plugins/elementor/assets/js/editor-modules.min.js?ver=3.4.5:2:16782] An invalid argument supplied as multiple control value [array (
‘category’ => ‘InvalidElementData’,
‘tag’ => ‘Element undefined got as exad_modal_image_gallery value. Expected array or object.’,

The other issue I notice is that none of my sites stay ‘Trusted’

Do you mean that when you create a new page in Elementor on the live site, it’s not automatically showing within Local?

A site in Local is completely separate from the remote site, so any changes that are made remotely will have to be synced down to the Local site somehow.

I’m not familiar with this error and it doesn’t appear to be related to Local. You might try reaching out to the Elementor plugin developers to get a better idea of what’s going on.

Can you describe this in a little more detail? Once you click the “Trust” button in Local, this only generates the certificate. You’ll still need to verify that the url within the browser is correct as well as update the url within the sites database.

More details about SSL in Local can be found in this help doc: https://localwp.com/help-docs/ssl/ssl-in-local/

Hi Ben
Yes, ‘Syncing’ is the problem. All the pages are visible and I have deleted the sample page. But the ‘Homepage’ viewed via the LocalWP dashboard is always a Vanilla default of the Elementor ‘Hello Theme’ titled ‘Archive’.

I noticed site health warnings, so I ‘cloned’ and upgraded the clone to PHP 7.4 and tried switching to Apache. - I can connect to Https, but still get warnings.

Site Health is happy that I upgraded to 7.4, but I am still unable to update cURL, using several methods - so this might be a problem.

I am also unable to fix fileinfo.dll missing - despite adding it to every php.ini and php.ini.hd I can find.

I notis when I run the site shell that imagick is not loading

With ‘Trust’ enabled I still get a warning - but it becomes unenabled if I click away/refresh.

Something that would help - which I can’t fine in the guidance - If an SSL crt was created - where would it be and what should it look like?

Thanks for your help with this

I sorted out the Homepage issue - I set up a site with Brizy instead of Elementor, had the same problem so figured out how to reset the home and preferred links.

But no luck with cURL or SSL - and now I’m getting 404 with new sites - Old sites still working.

Since this issue seems to be quite different from the one outlined in the original topic, I’ve moved the conversation to its own topic.

Do you have a more specific solution? I bet the community would be improved with knowing what was wrong and how to fix it!

The cURL issue sounds like something related to missing PHP extensions that we’re trying to fix with all the various versions of PHP.

As for the SSL issues, can you please provide your Local Log? See this Community Forum post for instructions on how to do so:

Hi Ben - I’ll have a go at a walk though when I’m off the sickbed - it’s a wordpress work around. I’ve done live sites and local severs - but this is my first local site and my first wordpress - I used Mac page builders, but not windows.

I’ve now tried all three PHPs with Apache - I’m yet to try PHP 8 with nginx - and I also want to give Maria a go. - I did quite a bit of Linux 15 years ago, so I’m familiar with PHP MySQL and Apache, but Maria, SSL, cURL and nginx are new.

The upside to IT problems is I can now find my way around the Local file system - with PHP 8 I managed to get cURL up to the latest version - yey! - same timeout and loop back warning - boo!

here’s my lightning log - please let me know if there is anything else to look at?
Thanks again
local-lightning.log (721.7 KB)

I’m now on nginx, MariaDB and PHP8. SSL and fileinfo & imagick problems still exist - cURL is temperamental.

fileinfo & imagick dll modules are not enabled in php.ini - imagick dll is missing from the extensions folder in PHP8 though it is present in 7.3 and 7.4…

Update - I now have a site with nginx, php 7.4.1 and MariaDB 10 and both fileinfo and Imagick modules are loading.

I have discovered that php 8 does not have imagick extension in the ext folder - so adding it to php.ini obviously made no difference.

I found a useful WP plugin using phpinfo() which shows what modules are loaded - so it’s not a ‘false positive’.

My goal is to build and demo a site - so the site has to be problem free - Still no luck with SSL - I have found all the certificates and the conf file appears to point to the correct folder.

This doesn’t appear to be a new problem - now I have the correct terms to search with:


1 Like


The issues you are finding with missing extensions are a body of work that we need to address. Right now the various versions of PHP don’t all have the same extensions compiled, and in some cases (ie Imagick on PHP 8) those extensions don’t even exist upstream.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.