ERR_CONNECTION_REFUSED - not finding a solution

Im getting an ERR_CONNECTION_REFUSED when I attempt to view any of my sites using Local.

I’ve been looking through other tickets and can’t seem to find a solution.

I’m on a mac, os 10.12, and recently updates to local 2.0.1.

I have cleared DNS Caches in Google Chrome Browser, i’ve tried Safari as well with no luck.

Any insight is appreciated, thanks.

Hi Roman,

Can you try running the following commands in Terminal and then provide the output here?

eval $(/Applications/Local\ by\ env local-by-flywheel)
/Applications/Local\ by\ ps

Also, can you provide your Local log file? You can find it by going to Help » Reveal Local’s Log.

Result 1:

Romans-Computer:~ roman$ eval $(/Applications/Local\ by\ env local-by-flywheel)
Romans-Computer:~ roman$ 
Romans-Computer:~ roman$ 

Result 2:

Romans-Computer:~ roman$ /Applications/Local\ by\ ps
CONTAINER ID        IMAGE               COMMAND                  CREATED             STATUS              PORTS                                                                                         NAMES
50dbe1b6c584        flywheel:1.0        "nginx -g 'daemon ..."   About an hour ago   Up About an hour>80/tcp,>443/tcp                                                      determined_ramanujan
3896c27ba065        local-by-flywheel   "/etc/scripts/slee..."   3 months ago        Up About an hour>80/tcp,>443/tcp,>1080/tcp,>3306/tcp   serene_mayer
Romans-Computer:~ roman$

the log is quite long, i’ve added it as an attachment

local-by-flywheel copy.log (244.4 KB)

Have you had a chance to look at this? If its a simple resolution I’d love to find out.


Hi Clay - did the log file provide any insights into my problem? I’d really like to get back to work using Local.



This is now in Local 2.0.3: Local by Flywheel 2.0.3 (macOS Only)

Hi Roman,

Can you please give this version a try? If it’s still acting weird, try going to Settings » Advanced and disabling “Faster Docker Volumes”

Thanks for your patience!

1 Like

Thanks - I have to step away from my computer at the moment, but i’ll respond with the results shortly.

Thank you for the support,

Nice! This fixed the issue I was having (Connection still refused on LbF2.0.2 by safari / firefox - connection refused (SOLVED))

Clay - that worked when I disable the “Faster Docker Volumes”

I have one last issue: I saved a site and now when I import it into Local and launch it, I get a “Your wp-config.php file has an empty database table prefix, which is not supported.” error. I’m not sure how to fix that.

Here is the config file:

 * The base configuration for WordPress
 * The wp-config.php creation script uses this file during the
 * installation. You don't have to use the web site, you can
 * copy this file to "wp-config.php" and fill in the values.
 * This file contains the following configurations:
 * * MySQL settings
 * * Secret keys
 * * Database table prefix
 * @link
 * @package WordPress

// ** MySQL settings ** //
/** The name of the database for WordPress */
define('DB_NAME', 'local');

/** MySQL database username */
define('DB_USER', 'root');

/** MySQL database password */
define('DB_PASSWORD', 'root');

/** MySQL hostname */
define('DB_HOST', 'localhost');

/** Database Charset to use in creating database tables. */
define('DB_CHARSET', 'utf8');

/** The Database Collate type. Don't change this if in doubt. */
define('DB_COLLATE', '');

 * Authentication Unique Keys and Salts.
 * Change these to different unique phrases!
 * You can generate these using the {@link secret-key service}
 * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
 * @since 2.6.0
define('AUTH_KEY',         'Gr2Apg9KETjfyzyD6qiZy9SRD7uDUK1OojtWKtiaQF7W4oZi9nYZgiRZjlp7rC9XSLxB4I/ipd8anyUWz8WRFg==');
define('SECURE_AUTH_KEY',  'ZLgmxw7HrcNm+w916Z5WM5tbGBO0E1s5r3moqgHMOjhp1JK5qvE/o43Q0yrRcEsQvka6N27GBEuqKBd07hLCJA==');
define('LOGGED_IN_KEY',    'IWNy35mtJanQYfXj4X06meCEMZPCoFbkPzdfvBzrAgH7NII0TD/WaNNJFbUZNS2lgCojnPdnnfXUXLiiAeGjgQ==');
define('NONCE_KEY',        '5O9cjAJg8MOIP9E6RzD4Uo0cspI1tPHJ+YOt3L6jFYEoRKrSNEngfMWHN4SK5WO1N6N2AWEHrYuZ/d3dawrC3g==');
define('AUTH_SALT',        'sx70+LFLWePeuSBfW4TZBEh8kcKzXCCRZgD9eVZohYuwp/CNojDOXZPvgchVcnT16muEEC9pCqBra55OoyUrPg==');
define('SECURE_AUTH_SALT', 'cHH5sb07EcyPzboKJ2os1SDtRurDWA+yPLSrH8ox3pCC4LQgNvu3I/Zi/kA6XmA2i4rgLs/dm6W4Vt0EZj58wA==');
define('LOGGED_IN_SALT',   '/L0ucpRH+zOvv9lUU2FTgL8+Jd8niHN1OHGM9kJHqbhINfLdE70/I6neO/2lwx44lS1p4mo/VIbP2xXK/DgInA==');
define('NONCE_SALT',       'aebw8heUpcpWbvs756rLNyxE4J4164OKz4iWyQ3Xq/n9hBkHUTf/nRiiksjNV2rGoXZ2Yxomyv0xTTVEy+XUgA==');

 * WordPress Database Table prefix.
 * You can have multiple installations in one database if you give each
 * a unique prefix. Only numbers, letters, and underscores please!
$table_prefix = '';

/* Inserted by Local by Flywheel. See: */
	$_SERVER['HTTPS'] = 'on';

/* That's all, stop editing! Happy blogging. */

/** Absolute path to the WordPress directory. */
if ( !defined('ABSPATH') )
	define('ABSPATH', dirname(__FILE__) . '/');

/** Sets up WordPress vars and included files. */
require_once(ABSPATH . 'wp-settings.php');

Here’s what you can do to fix that:

  1. Go to the Database tab for the site
  2. Open either Adminer or Sequel Pro
  3. Go to the local database and see what the prefix is. It should be something like wp_
  4. Change $table_prefix = ''; to $table_prefix = 'PREFIX_HERE';

Did you import this site into Local?

You are a genius @Clay,
It works perfectly now with this release and I don’t even have disabled “Faster Docker Volumes”.

Now I can start to work on my new project

Thanks a lot - very happy to test-drive LbF

1 Like

Haha, thanks Alain!

Thanks for taking the time to help out with the screen share :grinning: . It was hugely beneficial to solving this!

1 Like

It was a pleasure if it was of some help. I hope it can help many others.
I just moved my complete site to LbF and everything is running fine (except that Wordpress is telling me that WP4.7.5 is the latest release although it should be 4.7.7 or 4.7.8) - this is just a minor problem that I will solve by downloading the latest release from WP site.

best regards

Alain, 4.7.5 is currently the latest release. Trunk is now 4.8 RC2.

1 Like

Sorry @clay and @afragen, current fork is really 4.7.5.
I was misinformed by looking a video presenting of so 4.7.8 and was thinking that 4.7.7 was the current one (or 4.7.8).
The video didn’t say that the new version was yet available…

I did import it, but I exported it from the last version of Local that I had running. I’m not seeing where I can edit that prefix…