Error: 61: Connection refused

What issue or error are you experiencing?

I can no longer access my site, both the WP admin and the front end links aren’t working. I opened the error logs and I continuously get this error:

2023/11/23 15:01:59 [error] 88070#0: *27 kevent() reported that connect() failed (61: Connection refused) while connecting to upstream, client: ::1, server: triumfhouse2.local, request: “GET /wp-content/uploads/2023/05/FOOTER_NEW_COLORSBOTT0.75-2048x687.png HTTP/1.1”, upstream: “http://127.0.0.1:10014/wp-content/uploads/2023/05/FOOTER_NEW_COLORSBOTT0.75-2048x687.png”, host: “triumfhouse2.local”

I also get a notification from local that “this site’s Wordpress URL does not match the host set in Local” and when I click the fix button this pop up appears:

2023/11/23 15:01:59 [error] 88070#0: *27 kevent() reported that connect() failed (61: Connection refused) while connecting to upstream, client: ::1, server: triumfhouse2.local, request: “GET /wp-content/uploads/2023/05/FOOTER_NEW_COLORSBOTT0.75-2048x687.png HTTP/1.1”, upstream: “http://127.0.0.1:10014/wp-content/uploads/2023/05/FOOTER_NEW_COLORSBOTT0.75-2048x687.png”, host: “triumfhouse2.local”

but no solution is given and I can’t edit any of the other database details in local.

Thanks,


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

I created a new blank site that works fine so it doesn’t seem to be a Wordpress issue.

System Details

  • Local Version: Version 8.1.0+6514

  • Operating System (OS) and OS version:
    MacOS
    13.0.1 (22A400)
    Apple M1 Pro


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

If you create a new, blank site in Local can you access that okay? If you can, then you may want to try reimporting the site getting the errors. The steps would look like this:

  • Locate the site files on your machine, and save a copy of them to your desktop. If you click Go to Site Folder under your site name it should take you right to where they are located.
  • Once you have those copied, completely delete the site from Local
  • Restart Local/your machine
  • Reimport the site back into Local. You can refer here on how to Restore from only Local site files

Thanks Nick, yes when I create a blank site I can access it okay.

I followed the steps to reimport the site, but I still get an error. I have 403 error when I click the site link, and this error in the logs: Xdebug: [Step Debug] Could not connect to debugging client. Tried: localhost:9003 (fallback through xdebug.client_host/xdebug.client_port) :frowning:

Can you share your full local logs here for us? There are some different ways to access and share Local Logs. For us to be able to troubleshoot thoroughly, please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information to help quickly zero in on any issues that Local is encountering.

Here are the logs:
local-logs.zip (46.7 KB)

Based on the logs it looks like there might be a port conflict occurring. Here are some steps to help us identify and address this:

  • Stop all sites that are running in Local

  • Force quit Local

  • (If using Mac) Run the command lsof -nP -iTCP -sTCP:LISTEN

  • (If using Windows) Run the command netstat -ano

What you’ll be looking for here is to see when sites are stopped and Local is properly shut down if there are still programs running on ports 80 and 443. These may be conflicting with Local or the system may be reporting Local is still running.

Once you run that command you should see a list of listening ports. If you see a particular program making use of those ports, you can then kill that process by running sudo kill -9 XXX where XXX is the PID number of that process. (On Windows you will use taskkill /F /pid XXX where XXX is the PID number of that process)

There are also some more details around this and other troubleshooting steps at this link if needed: Stopping Whatever Is Listening On Port 80.

Keep us posted!

I don’t see any programs using the ports in the list. When I opened local again I got this error at the top about the database location:

In order to refresh here and start with a clean slate could you give the below troubleshooting steps a try?

Keep us posted and we’d be happy to help further!

Hello, I tried this solution twice and still am unable to open the site. Here are the logs:
local-lightning-verbose0.log (424.2 KB)
local-details.json (721 Bytes)
error.log (187.6 KB)

Can you detail some more what errors or issues you’re still seeing?

If you create a new, blank site in Local what error do you get?

If you try to reimport a former site what happens?

If you change your Router Mode to Localhost are you able to proceed? Preferences>Advanced>Router Mode>Localhost

Please share screenshots or a short video if that helps!

This is what it says in the local panel:

I get a 404 error whenever I try to open the WP admin and a 403 error when I try to open the site.

If I create a new site with the same default settings I have when I import my current site everything works as expected.

After I created the new site, the old site wasn’t able to complete stopping and I had to force quit local and when I reopened it and tried to start the site I got this error:

I’m glad you were able to create a new site and that works as expected. That’s a good sign! Can you try reimporting the site that isn’t working now and see if the errors persist? Or did you try that already and got the error?

I still get the same things as before when I import the zip file. This is the error it gives me right away: