Error after upgraden Pressmatic to Local

My current sites aren’t working anymore, Ngrok config is also messed.
Can you guys direct me into the correct direction?

( ! ) Fatal error: Cannot redeclare make_link_ngrok() (previously declared in /app/public/wp-content/mu-plugins/local-by-flywheel-demo-urls.php:84) in /app/public/wp-content/mu-plugins/pressmatic-tunnel.php on line 84

Uploading… Uploading…

Sorry for the trouble!

Please go to Local and disable the Demo URL. Then open up your site’s app/public/wp-content/mu-plugins folder and remove the Pressmatic and Local PHP files if they exist.

After that you should be able to re-enable the Demo URLs.


Ngrok works beter than before imho, I’ve had issues with it not loading before.

Succes with your new challenge :slight_smile:

1 Like

Can you walk me through the process of switching from Pressmatic to local - I uninstalled the pressmatic app, and installed local as I understood to be the plan, but nothing works apart from one site and new sites just hang at adding

I uninstalled Local, deleted preferences etc and started from a clean slate importing my old sites from zipped backups - that seems to be working better than trying to swap local for pressmatic.

Bit more work, but it’ll be okay for me.

It definitely shouldn’t require all of that but glad you got it working either way :slight_smile:

I’d hoped it wouldn’t have needed it, but when I substituted Local for Pressmatic it found all my sites but only a couple of them worked and new sites didn’t finish creating…

Is there anyway I can run pressmatic on my machine? I have a few sites that didn’t export properly so they won’t import.

can I get the pressmatic latest version from somewhere to try?


Do you know what is happening specifically? Rolling back may create more issues.

Can you send your log file to

Sorry for the trouble!

No worries, I’m probably best off where I am then. What happened was that of the 20 or so sites only a couple were found. I think it might have been a hosts issue. I rebooted the machine, and tried creating a new site in local and that just hung. Interestingly as I type I have a new from blueprint site hung at adding and a site export hanging as well.

Log sent to see if it helps.

I’m seeing this error in the log:

Error response from daemon: driver failed programming external connectivity on endpoint […] iptables failed: iptables

After a quick Google you may have success with this workaround if you’re comfortable in Terminal: