Error at end of importing a WP 2.9.2 site - Error: WP-CLI needs WP 3.7

Issue Summary

I am new to Local.
The webhost went from PHP 5.6 to 7.3; breaking a couple personal WordPress 2.9.2 sites.
Hoping to run the WP site locally to test upgrading WP, plugins, etc. before I try this live on the server.
Local seems to do the entire import, iterating through folder and files; but then errors at the very end.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    Have not tested another option. Don’t know of other option.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?


Screen Shot 2021-01-23 at 10.13.10 AM

I should note that I tested this with a simpler & smaller 20 page blog that also was, 2.9.2 afaik, and it worked fine.

System Details

  • Which version of Local is being used?
    Latest as of 2020/01/22

  • What Operating System (OS) and OS version is being used?
    OS X 10.15.x

  • Attach the Local Log. See this Community Forum post for instructions on how to do so:

Hoping somebody can provide more information, as to what the error means, and hopefully point me in the right direction as to make it work. Fingers crossed.

Some extra information:

Regarding the Wordpress install / blog structure.

It has one small change compared to the standard WP install.

There is a primary index page on the root, and the wordpress blog is under / blog ; as the site has three different sections.


Website Root:


wp-files and the various folders

So, I have tried a zip file with absolutely everything html etc from the root index.php, four folders + the sql database.
It seems to work but had additional errors:

I have tried a zip file of the just the wordpress content in / blog + the sql database.
I think it is pretty close, as it imports for a good while, except for that error.

Screen Shot 2021-01-23 at 10.13.10 AM

I am hoping somebody can shed some light and can share a fix.

Noting that: due to the web host forcing an upgrade from php 5.6 to 7.3; I am unable to log into the wordpress install on the server, and can’t update, export, etc. It throws an error in line 600+ of wordpress settings. And is basically an old wordpress is not compatible with newer php type of thing.

It seems you have imported all the core WP files too. The error very specifically states WP-CLI doesn’t work with your installed version of WP.

What you will need to do is zip the sql file of your database and your wp-content folder and then import that into Local. This should create a new installation with WP 5.6 which should work.

Thank you,
I will play around with it some more, and try that combination of files.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.