Import From WP Site Failed

Issue Summary

Data and settings from my WP site failed to import into Local app

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

I only tried it on one site - my personal WP site.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?



Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

I was hoping to download data/content/settings from my ‘production’ Wordpress website and import that to a version of my site, so I could then use the local site as a ‘sandbox’ to dev and try/test out new things.

I downloaded my site via the ‘BackWPup’ plugin as suggested on the Local site/app. When I tried to import the ZIP file containing the back up info, I got the error on the screenshot below. Any thoughts or suggestions as to what maybe the issue and if it is a simple fix or something more involved? Is the SQL format on my production WP site compromised compared to whatever method uses to read those files? Is there another way to import data like posts and pages from my production WP site? Can I just upload the standard XML download from WP itself?

System Details

  • Which version of Local is being used?

Most updated -

  • What Operating System (OS) and OS version is being used?

Mac OS Monterey 12.1

  • Attach the Local Log. See this Help Doc for instructions on how to do so: (3.0 KB)

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.