Error command failed: Callable [null,null] does not exist, and cannot be registered as "wp server"

Error command failed: Callable [null,null] does not exist, and cannot be registered as “wp server”

Issue Summary

Error while installing on windows
I can’t get local installed on my computer, it always returns an error saying “Error installing Wordpress”
Error command failed: Callable [null,null] does not exist, and cannot be registered as “wp server”.
I can’t find solution by googling or on your support forum.

“stack”:“Error: Command failed: %%resourcesPath%%\lightning-services\mariadb-10.4.10+4\bin\win32\bin\mysql.exe --password= -e ALTER USER ‘root’@‘localhost’ IDENTIFIED WITH mysql_native_password BY ‘root’;\nERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: NO)\r\n\n at ChildProcess.exithandler (child_process.js:317:12)\n at ChildProcess.emit (events.js:315:20)\n at ChildProcess.EventEmitter.emit (domain.js:467:12)\n at maybeClose (internal/child_process.js:1048:16)\n at Process.ChildProcess._handle.onexit (internal/child_process.js:288:5)”,“level”:“error”,“message”:“Error setting up MySQL user”,“timestamp”:“2021-08-03T14:07:55.807Z”}

If you enter adminer you get the error:
Access denied for user ‘root@localhost’ and can’t modify permission from inside.


Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    also the previous version 6.0

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?



Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

Ez, Download, Install, Create a new site with any option.

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?
    Windows 10 Home

  • Attach the Local Log. See this Community Forum post for instructions on how to do so:

local-lightning.log (27.7 KB)


I’ve never seen that error before:

Error: Callable [null,null] does not exist, and cannot be registered as `wp server`.

It does feel like an error that wpcli would throw and from searching online for:

wpcli Error: Callable does not exist

that seems to indicate that for some reason, wpcli isn’t finding the actual php functions it needs in order to complete the command.

Can you describe in a little more detail what the computer’s dev environment looks like? For example, have you manually installed PHP directly on Windows? What about wpcli – do you have that installed globally, or in some way written your own wpcli packages?

The reason I’m curious about your environment is that Local doesn’t use the wp server command, and so something is trying to launch PHP’s built in development server when Local is trying to configure a new WP site.

Nice point of attention.
I have wp-cli installed (my own) in C:\wp-cli

If I open the cmd and i just type wp and press enter I got the same error as the post tile here.
Uninstalled the wp-cli from cmd and then retried the installation, it worked!

Many Thanks!
you can close this thread.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.