Error for MariaDB

Issue Summary

I have exported website using WP Migrate (full backup) to zip and tried importing it in Local (started with elevated rights). Then I encountered an error:

Error: Command failed: C:\Program Files (x86)\Local\resources\extraResources\lightning-services\mariadb-10.4.10+4\bin\win32\bin\mysqladmin.exe ping
aC:\Program Files (x86)\Local\resources\extraResources\lightning-services\mariadb-10.4.10+4\bin\win32\bin\mysqladmin.exe: connect to server at ‘’ failed
error: ‘Can’t connect to MySQL server on ‘’ (10061)’
Check that mysqld is running and that the socket: ‘MySQL’ exists!

at ChildProcess.exithandler (node:child_process:407:12)
at ChildProcess.emit (node:events:527:28)
at maybeClose (node:internal/child_process:1092:16)
at ChildProcess._handle.onexit (node:internal/child_process:302:5) (2.4 KB)

In the zip file I’ve replaced computer name and one hex value with word redacted, other part of the logs is intact.

I have also checked netstat -ano but I don’t see port 10061 there on the list.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    I have tried it with only one site.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    I haven’t tried.

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?
    Windows 10 Professional x64

  • Attach the Local Log. See this Help Doc for instructions on how to do so:
    Attached above

Hi @wordpressadept

Do you have any antivirus, security, or firewall applications that could be blocking Local? It looks like from the log it might be having trouble connecting.

More details about troubleshooting this here: Router Mode

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.