"Error: Command Failed" when installing WordPress on Windows

Unfortunately the issue is still there with Local 5.6.8+4514 (Windows 10 2004)

Thanks for confirming @hexaae

Can you please provide your Local Log? See this Community Forum post for instructions on how to do so:

I’m curious to see what kinds of errors Local is reporting!


and this is the log in the exact moment of the screenshot: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

Hey @hexaae – I’m having trouble recreating this issue on my end. Let’s think through the things we now to be 100% true. Looking at the log, it seems like:

  1. Local appears to be able to successfully create the database.
  2. Local appears to have been able to update the Hosts file
  3. WordPress appears to have been downloaded and installed
  4. The last command that appears to be erroring is the wpcli command to remove the default plugins

Are you able to start one of the other sites that were created created before and access it?

When you do start the other site, are you able to right-click on the site and select “Open Site Shell”?

If a terminal opens, can you try interacting with the site using wpcli? So for example, try:

wp plugin list
wp plugin delete akismet hello

Yes I can access and start the WP site. I agree it seems a problem in the last part with the WP plugins automated commands… Script fails because it can’t find akismet plugin?

Setting Local environment variables...
----
WP-CLI: WP-CLI 2.5.0-alpha
Composer: Composer version 1.10.8 2020-06-24 21:23:30
PHP: 7.3.5
MySQL: mysql  Ver 8.0.16 for Win64 on x86_64 (MySQL Community Server - GPL)
----
Loaded Shell for Local Site: test1
----

C:\Users\Luca\Local Sites\test1\app\public>wp plugin list
+-------+----------+--------+---------+
| name  | status   | update | version |
+-------+----------+--------+---------+
| hello | inactive | none   | 1.7.2   |
+-------+----------+--------+---------+

C:\Users\Luca\Local Sites\test1\app\public>wp plugin delete akismet hello
Warning: The 'akismet' plugin could not be found.

C:\Users\Luca\Local Sites\test1\app\public>

Unfortunately the issue is still there with Local 5.6.10+4674 (Windows 10)
Screenshot_191

Hey @dinhvuongfx, Welcome to the Local Community Forums and thanks for the screenshot! Can you please provide your Local Log? See this Community Forum post for instructions on how to do so:

I did try recreating this one more time and Windows was able to create a new site for me.

When you encounter this error, what things are going on? For example, are you running other software while Local is creating the site? Do you have focus on a different window, for example any text editors that have files open within that site?

5.7.2+4801 bug still reproducible, always same error trying to delete akismet + hello dolly plugins:

local-lightning.log: https://hastebin.com/isezonokah.json

Version 5.7.4+4876, issue still reproducible.

5.7.5, Wordpress install script still fails trying to delete inexistent plugins “hello” “akismet”.
Would be so hard to remove that part of the script and let users decide what to delete after default WP installation, since it causes more troubles than it solves…?

@ben.turner
Still happens with 5.9.0.
Tried also to clean-up everything uninstalling Local and manually deleting:
C:\Users\Luca\AppData\Local\Programs\Local
C:\Users\Luca\AppData\Roaming\Local
but on re-Install still didn’t work. Always fails with error when it has to delete those default plugins.

{“thread”:“main”,“class”:“WordPressInstaller”,“message”:“Installing WordPress”,“level”:“info”,“timestamp”:“2020-11-01T00:04:38.805Z”}
{“thread”:“main”,“class”:“WordPressInstaller”,“message”:“Deleting Akismet and Hello Dolly”,“level”:“info”,“timestamp”:“2020-11-01T00:04:40.002Z”}
{“thread”:“main”,“class”:“WordPressInstaller”,“stack”:“Error: Command failed: "%%resourcesPath%%\lightning-services\php-7.3.5+10\bin\win64\php.exe" "%%resourcesPath%%\bin\wp-cli\wp-cli.phar" --path="C:\Users\Luca\Local Sites\007\app\public" --require="%%resourcesPath%%\bin\wp-cli\local-wpcli-error-reporting.php" --skip-plugins --skip-themes "plugin" "delete" "akismet" "hello"\n\n at ChildProcess.exithandler (child_process.js:304:12)\n at ChildProcess.emit (events.js:223:5)\n at ChildProcess.EventEmitter.emit (domain.js:475:20)\n at maybeClose (internal/child_process.js:1021:16)\n at Process.ChildProcess._handle.onexit (internal/child_process.js:283:5)”,“level”:“error”,“message”:“Error installing WordPress”,“timestamp”:“2020-11-01T00:04:41.396Z”}

It’s a problem with “php.exe” execution.

5.9.7

Bug fixes

  • Fixed regression that caused site services to not be properly stopped after Local was quit.
  • Modified install process to not fail if Hello Dolly or Akismet can’t be deleted.
  • Fixed bug related to pushing database changes to WP Engine with WordPress 5.6.

Is everything working as expected with the latest version of Local?

Yes. Finally solved! :slight_smile:
I can find Hello Dolly still installed the first time I enter the new site, but WP installation now ends without issues!
Got more time than I expected to get fixed, but… thank you and a happy new year!

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.