"Error installing WordPress" when using PHP 8.2

What issue or error are you experiencing?

Thanks for your work adding PHP 8.2, unfortunately it’s not working for me. Not sure if I’m a special case :slight_smile:

If I try to add a new site with PHP 8.2 I get a large error popup, the root complaint in it seems to be “…/.config/Local/lightning-services/php-8.2.8+0/bin/linux/bin/php:/lib/x86_64-linux-gnu/libm.so.6:version `GLIBC_2.35’ not found” - see screenshot & logs

I also noticed if I try to switch an existing installation to PHP 8.2 from an earlier version of PHP then it says it’s switched but the browser shows a gateway error. Presumably it’s the same issue, just with less feedback. (“Service Unavailable” using Apache, “502 Bad Gateway” using nginx)

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

Create a new site. Select custom: PHP 8.2, nginx, MySQL 5

I can still create a site successfully using PHP 8.1/nginx/MySQL5

System Details

  • Local Version:


  • Operating System (OS) and OS version:

Debian 11

Note I’m also using the localhost router mode because site domains doesn’t seem to work under Debian (it worked fine under Ubuntu. I’ve found Debian is a little more protective about some things). Might be related, might not. No big deal but could raise a separate report if this was news.

I noticed that under “Advanced Options” on the “What’s your site’s name?” setup page, it shows “Local site domain” as “test.local” (or equivalent for different sites) even though I’m configured for localhost router mode - but I’m thinking this probably isn’t significant as it’s present when I successfully setup PHP 8.1 sites as well

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

local-lightning.log (730.0 KB)
(I took a chunk out of the middle of the log where it included our client names, but I think that was all very old logs anyway)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @jonjennings - I just got word from @adamperry one of our Local Devs that this should be resolved now! You should see an Update button next to an existing 8.2.8 site.

1 Like

Wow - thanks for the quick turnaround.

TL;DR: this works.

Longer version:
I tried to switch an existing PHP 8.1 site to 8.2 and that sat doing the PHP Swap forever.
Restarted Local and site shows PHP 8.2.8 with the update button next to it.
Clicking that gives me “update PHP 8.2.8+0 to PHP 8.2.8+1” popup.
That downloads & updates correctly, site shows 8.2.8 in Local
Website still shows “502 Bad Gateway”
Restarted Local
Site won’t start, says “Provisioning” and sits there forever.
Restart Local
Move site back to PHP 8.0 and site is now on a different port and says “Error establishing a database connection”

Created a new fresh PHP 8.2 site - that works fine
Created a new fresh PHP 8.1 site and then converted it to PHP 8.2 - works fine.
Switched a different, previously created site to PHP 8.2 - that works fine!

So looks like I had some issues getting the +0 to +1 update installed and I had to trash a site to get it setup but, now it’s in, it seems faultless.

And I can see Imagick in PHP 8.2 - THANK YOU! Looking forward to migrating our Imagick-dependent sites back into Local and will update on those tickets once we’ve tested that. Oh wait - those sites are going to need some (haha - and I thought 8.1 to 8.2 was going to be trivial) PHP 8.2 work to fix all those new deprecations… so that might be a while :slight_smile:

Thanks again.


Haha glad you got things up and running there! Thank you for your follow-up and for letting us know where you stand. If you have any other questions or concerns down the road you know where to find us :slight_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.