Error installing wp-graphql-acf plugin when creating a new site

What issue or error are you experiencing?

Receiving the follower error when trying to create a new site, which hangs the install process on “Installing Wordpress plugins…”

Error: Command failed: /Users/…/Library/Application Support/Local/lightning-services/php-8.1.23+0/bin/darwin-arm64/bin/php /Applications/Local.app/Contents/Resources/extraResources/bin/wp-cli/wp-cli.phar --path=/Users/…/Documents/WORK/__localwp/my-website/app/public --require=/Applications/Local.app/Contents/Resources/extraResources/bin/wp-cli/local-wpcli-error-reporting.php --skip-plugins --skip-themes plugin install --activate https://github.com/wp-graphql/wpgraphql-acf/releases/latest/download/wp-graphql-acf.zip

Warning: Download failed. “Not Found”

Warning: The ‘https://github.com/wp-graphql/wpgraphql-acf/releases/latest/download/wp-graphql-acf.zip’ plugin could not be found.

Error: No plugins installed.


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

create a new site


System Details

  • Local Version:

Version 8.0.0+6475

  • Operating System (OS) and OS version:
    Mac Studio 2022 / M1 Ultra
    Mac OS Ventura 13.4.1

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

local-logs.zip (24.8 KB)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Screenshot 2023-10-11 at 4.29.05 PM

Hi @droplab

It looks like you’re using Apple Silicon. Do you have Rosetta installed? This is necessary for all Apple Silicon installs at this time (we plan to do away with that in the near future).

Hi, thanks for the response. I think I’m running a silicon version of the app

image

An additional note, the issue happens when I try to create a site from an Atlas blueprint (Faust Scaffold) and the download link for wp-graphql-acf is a 404. Creating a site without using an atlas blueprint seems to work fine.

When you create the site are you using NGINX or Apache as your server type? If you’re using NGINX could you try switching?

When creating a site from a blueprint, it doesn’t seem to give an option for which webserver to use. It just starts installing everything.

Hi @droplab - Sorry about that, I see what you mean now. I just went through and tested it myself and got the same error. Let me check with the Devs on this!

Following up here @droplab! Looks like this was an accidental break due to a change in a recent release. The team is looking into getting this fixed now. I’ll update you here as soon as it’s done!

In the meantime you can download and install manually if needed using this link:

https://github.com/getflywheel/local-addon-atlas/files/12895192/getflywheel-local-addon-headless-1.7.2.tgz

Thanks @Nick-B! The quick action on this is really impressive.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.