I cannot create a website (M3 apple silicon)

Hi guys todays my first day creating a website and I ran into an error.
I clicked on the add site option, with preferred environment, and entered login credentials but got the following error:

Uh-oh! Unable to provision site.
Error: Error: spawn Unknown system error -86

at ChildProcess.spawn (node:internal/child_process:414:11)

at spawn (node:child_process:776:9)

at execFile (node:child_process:351:17)

at t. (node:electron/js2c/node_init:2:2610)

at /Volumes/Install Local/Local.app/Contents/Resources/app.asar/main/_helpers/execFilePromise.js:1:583

at new Promise ()

at Object. (/Volumes/Install Local/Local.app/Contents/Resources/app.asar/main/_helpers/execFilePromise.js:1:534)

at Generator.next ()

at /Volumes/Install Local/Local.app/Contents/Resources/app.asar/main/_helpers/execFilePromise.js:1:330

at new Promise ()

and then the following pop-up saying “Uh-oh! Could not update the host files. Local ran into a problem while trying to update the host file. Please ensure that the host file is not locked by anti-virus”

So there’s two things I’m new to, the MacOS (v14.3) and then Local (latest version), Wordpress etc.

Screenshot 2024-05-07 at 15.46.45|690x370
local-logs.zip (4.1 KB)

Hi, @Sid_c. Please could you try:

  1. Quitting Local.

  2. Opening a terminal and entering this command:

    softwareupdate --install-rosetta --agree-to-license
    
  3. Opening Local again.

2 Likes

How did this work? What was missing? I was running into the same issue. Could you please explain this?

@abdnafees Local currently requires Rosetta on Apple Silicon to provide support for parts of Local that use Intel binaries (such as nginx and a password prompt utility). We have plans to make Local fully Silicon native but I don’t have a timeline for this just yet. I’m glad the fix worked for you, though!

1 Like

Got it, sounds good.