Error when Importing CSV and XML files - "Failed to move uploaded file"

Good morning everyone,

Currently working on a Woocommerce webshop using local Local to host it while I am building the website.

I have installed: WP All Import plugin and WP All Import - WooCommerce Add-On plugin.

When I try to import products with an XML (13K) or a CSV (7K) file it gives me the following error: “Failed to move uploaded file”

Any clues on what may be and how to solve it?

I tried bigger and smaller files and always ended up with the same result. Also contacted the WP Import support team and they were able to import the files on their test website with no issues.

Thanks in advance.

Hi @miguelvieira

You might have to try raising some of your settings like upload file size and timeout.

These values can be edited in the php.ini.hbs file within the site’s conf/php/ folder. After making any adjustments, be sure to stop the site and re-start it so that Local can compile and use those new settings.


thanks for coming back to me. Just gave a look at the php.ini.hbs file and had the following settings:

uploud_max_filesize = 300M
mysql.connect_timeout = 60
default_socket_timeout = 60

According to the size of my files ( XML13K and a CSV 7K) the default max upload size shouldn’t be a problem. Even so, I changed them to the following:

upload_max_filesize = 30000M
max_file_uploads = 2000
mysql.connect_timeout = 60000
default_socket_timeout = 60000

I am still getting the same error message when trying to upload my files “Failed to move uploaded file”.

May the timeout be the cause of the issue? If you can give it a look, I may send you by email my php.ini.hbs file and the files I am trying to import.

Hi @miguelvieira

Specifically you could try adjusting PHP settings like memory_limit and max_execution_time to see if that makes a difference as well.

Hi @Nick-B

I had memory_limit at 256M and max_execution_time at 1200. Just adjusted them to 25600M and 120000 respectively… but still no luck.

And if you break the files up smaller they still won’t import you said? How small did you break them up?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.