EXTREMELY slow load for one of the websites and no CSS

I have two sites running on Local. One of them is doing fine. The other was doing fine but now it is loading extremely slowly. Like according to chrome dev tools it took 4.8 minutes to load. And a lot of the assets aren’t being loaded, such as most of the images and the styles.css file.

Also I already turned on faster docker option, and I’m not using xDebug which seems to be the thing a lot of people have had problems with.

EDIT: okay so I shut down Local and then spun stuff back up. When I opened it up it had to do the whole check on virtual box, host machine, etc all over again, don’t know why. But maybe that’s a clue.

EDIT EDIT: When I switch from nginix to apache it gives me a 500 Server error. The htacess file should just the be default one created by Local though.

EDIT EDIT EDIT: Other weird stuff. On nginx it gives me a 500 error on the wp-admin but lets me get to adminer (which it wouldn’t let me on Apache). Also when it gives me the 500 error on the wp-admin it changes the url over to localhost:8888 which is, of course the default host for MAMP which I was previously running but am no longer running.

Also I thought I had faster docker containers enabled but no matter how many times I hit apply, as soon as I go to a different page and come back it is just shows it reverted to disabled.

I’ve also turned on dev mode because that helps with caching correct?

EDIT EDIT EDIT EDIT: I found further weirdness. the images that won’t appear show their url in chrome dev tools as localhostlocalhost/wp-content/uploads/2.jpg

If I put in the same url that Local has tagged as my sitedomain, jackalopelocal.local then add wp-content/uploads/3.jpg then I get the proper image.

So it seems to me that it has something to do with the site url settings in my db.

Originally when I imported they were localhost:8888

Since the wp-config created by Local has localhost as the db host I put that in the site url.

I didn’t find the weird image url problem till after I had made this change. but I’m pretty sure the weird localhostlocalhost repeat in the url has something to do with the database site url. I’m going to reference this against my working website and see if that fixes the issue.

I just tried my other website and it’s working fine so there’s something screwy with this other one.

Log file is attached. local-by-flywheel.log (45.6 KB)

So I went to the database on my other website and I checked what the site url was. From that I gathered that I needed to change my problem website url to jackalopelocal.local. I did this and this mostly worked. Some of my images that relied on site_root_url() didn’t work for some reason so I had to remove those.

None of my links work though. I can only see the front page and that’s it.

EDIT: So I went to the wp-admin to see if maybe there was some setting I needed to hit in the permalink settings. Nada. so I decided to view those sections byclicking on the view from the post archive page in admin. And that worked. And the url looked the same as it did on the front page when it didn’t work. So then I went to the front page and clicked stuff and now it works… wtf?

This is a really great UI and I’m really excited about it, but there are so many weird little quirks. There seems to lots of little things that don’t work, or work differently and I’m not sure why since it seems like hypothetically running apache on MAMP should be the same as running Apache on here right?

It sounds like most of the issues stemmed from the site still having the old development URL like you mentioned. Local will try to automatically find and replace these when you import the site using Local’s importer. However, if you have different development URLs on the same site, it will only be able to replace one.

You may need to run another search and replace. Here are instructions on how to do so: New Local site created from archive not working

If this is happening then Faster Docker Volumes is failing to enable. You can check the local-by-flywheel.log file for more details.

You may have better luck with the 2.2.0 pre-release.

Thanks @clay Stuff is up to speed once I made the changes to siteurl. I did the search-replace anyway and it replaced 680 locations so that seems like a good thing. There’s still a lot of funky action going on, and not entirely sure why but I guess I figure it out.

Hey David,

Glad to hear you saw a speed increase after changing the site URL!

Are you still running into other issues?

1 Like

Nope looks like everything is good. Thanks!