Forms not working in local

I am developing a Wordpress site using local and I am using WP forms for my contact form. I have tried sending a couple of test messages using the form, but it does not get delivered. Is there something I need to do to get this to work? Or will it not work from local?

Hi Abe,

It should work. Can you please try going to Help » Restart Local’s Machine? Sometimes there’s an outbound networking issue with VirtualBox that can be easily resolved by doing this.

Also, are you seeing any errors in WPForms?

Will refreshing the local machine generate a new live link? My client is getting confused each time I send a new live link.

The Live Link should stay the same.

I’ve restarted and tested again. No emails received. No error messages in WP Forms


I used WP Forms too but from my understanding I do not receive those emails in my real email account when we are developing on local, they appear in the Local by Flywheel’s utilities -> Mail Hog.

Maybe you can check it out over there.

OK, I found mail hog under utilities. I click on it and I see something flash in my dock (iMac) and a new tab opens in my Google Chrome browser, but it is blank…am I missing something here?

And just to be clear, I am using Local only…not flywheel

Hi @abu117,

Can you please screenshot your browser after clicking the MailHog button?

Like I said, it opens a new chrome window, but its blank:

I was able to resolve this by changing my default browser to Safari from Chrome. I’m noticing Chrome is doing this for all links now which prompted me to set Safari as the default.

1 Like


That’s interesting! Glad you got it solved :slight_smile: