Getting Started Guide

Is there a getting started guide for Local? Specifically I am looking for how to export a currently running website on my own site and import it into Local.

Did you hear back about this? I was looking for the same thing…can’t see any basic start up help anywhere! :slight_smile:

no, I have not

I would be really interested in how to import a live website guide, that would be very helpful

Hey all,

I’ll pass this along to the content team to make a thorough guide :slight_smile:

For now, if you’re not on Flywheel then I recommend using a product such as Duplicator or BackupBuddy to create a backup of your site that you can import into Local.

After downloading the full backup, drag and drop it onto either Local’s Dock icon or window and it’ll start the import. Please note, you need Local 1.4.1 or newer.

I tried Duplicator but it did not work to download my site which is 11 years old and has lots of content

Clay, I dragged the duplicator zip onto local, and the new site was created, but when I open the site I get redirected to the live site instead of the dev copy. How can I fix this?



I’d open the site database with Adminer or Sequel Pro, then go to wp_options and see if the home and siteurl options are set correctly.

If not, try the following:

  1. Right-click on the site and go to Open Site SSH
  2. After the Terminal opens you can use WP-CLI to change the old URL to the new. Here’s the documentation (
    • Example: wp search-replace "//" "//"

Thanks Clay. I’m a little over my head here. I should mention this is on a PC not a Mac.

Using WP-CLI the search and replace resulted in zero changes. So I deleted the site and added the archive file to local again. The result was the same. Opening the dev site redirects to live site.

Using Adminer (again), I see that siteurl and home are set to the dev url that Local automatically created.

Looking forward to documentation. Until then, I welcome any advice from users.


Interesting. The actual configs for the imported site may not be properly updated or the router’s may not be getting updated.

In case you haven’t tried this yet: try restarting the site after importing. That will reinitialize the router.

If possible, can you send me the archive you’re trying to import? You can private message me the link to it here on the forums or e-mail

Sorry for the trouble!

Thanks Clay, i just shared a folder with you via google drive.

Is there a getting started guide? Documentation? I really don’t know how to use this and need to know the basics.