Head tag not loading css/js in imported theme, other themes work fine

I’m a developer at a new position and I’m trying to set up my employer’s site as a local development environment using the primary theme from our site. The site has three themes on it and when I copied over the themes to Local two of them worked perfectly but the third (primary theme) did not. Although it imported without an issue when it is set nothing in the head tag loads (I checked in developer mode) so it’s just plain html. I’ve tried checking the header.php and function.php files and nothing seems off there and the paths to the associated files are all relative so I’m not sure why they’re not loading.

I spoke with our previous developer and he said that going into the theme settings and saving it would get it going but that hasn’t worked either. Any suggestions?

This is definitely an odd situation and something that feels pretty site specific so I moved it to the general WordPress category.

I guess the main thing that comes to my mind is to ensure that the correct header.php file is being use (sometimes themes have more than one) as well as verify that the wp_head() function is in that template and is actually being run.

One other thing that comes to mind – you mention that this is a “primary theme” – is it correctly activated? For example, there isn’t a child theme that is taking precedent over this one is there?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.