How do I re-download my site from WPEngine?

What issue or error are you experiencing?

When I try to re-download the site from WPEngine by clicking on the cloud icon with the down-arrow in it in the lower right of Local (Pull from WPEngine), Local comes back with a dialog with a dropdown “Pull site from”. I see a list of our sites that live on WPEngine but the site I need is grayed out and it says “Already connected to local”. So, how do I get it to re-download?

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version:

  • Operating System (OS) and OS version:

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @Owen37!

Have you tried any reboots of the Local app or your machine yet to see if that makes a difference?

You might also try resetting your API connection to WPE:

As a workaround, you should be able to download a backup and direct import that into Local:

Yes. I’ve tried rebooting the local version several times.

One issue: I had both my dev and prod environments on my local machine running in local. Once I disconnected the prod instance, the dev instance was able to download again.

However, I can’t get the dev instance to work properly on my local machine. Works fine on WPEngine, but when I download to local (using Local), I get infinite loop errors (even when running the browser in private mode) when I try to go to the admin dashboard)…


Your machine might be confused if you were working on both at the same time. Have you tried checking it in another browser? You could also test on another network, with a VPN or mobile hotspot to see if that gets around anything stuck on the network.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.