How to enable Loopback Connection support

What issue or error are you experiencing?

I am running a WooCommerce site running WooCommerce Customer / Order / Coupon Export and have been struggling to get the orders to export. One of the items, background processing, requires loopback connection turned on. When i check WooCommerce > Status > Tools and run the background processing test, it fails with the following: “Could not connect. Please ask your hosting company to ensure your server has loopback connections enabled.”

I found another topic here with the exact issue from a couple of years ago. The solution was to download the newer version of Local, but at this point my current version (which should be the latest) is well ahead of that one. Is there an option or a PHP config setting I need to change to get this to work?

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version:
    Version 7.2.1+6433

  • Operating System (OS) and OS version:
    MacOS - 13.5.2 (22G91)

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

local-lightning.log (60.3 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @egrissom

Are you using Apache as your server type?

It looks like another user created a post here with a lot more detail that might be helpful in troubleshooting:

I was not, I was using nginx. Do I need to be running Apache?

It seems like the issue is mostly when using Apache, so I don’t think switching would resolve it.

Doing some searching online, it looks like this could also be a plugin conflict. So you could try disabling your other plugins to see if that resolves the error.

From Woocommerce’s documentation, another troubleshooting step to try is this:

Alternatively, wait for the process to get stuck, use the Clear Square Sync option under WooCommerce > Status > Tools, and start the import again. Repeat the process until no further products are imported. The log will be marked with Completed step cycle: update_inventory_counts.

I’ll look into plugin conflicts. I’m not using the Square plugin, but it could be another.

Sounds good @egrissom! Let us know if you’re able to get it resolved.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.